FF1.5 does not do align=RIGHT for <INPUT type=text>

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: ysato, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

align=RIGHT in INPUT tag does not align the text right in Firefox1.5.

ex. <form><input type=text value="x" ALIGN=RIGHT></form>

Reproducible: Always

Steps to Reproduce:
1.display HTML data as <form><input type=text value="x" ALIGN=RIGHT></form>
2.
3.

Actual Results:  
The "x" displayed is not aligned to right in the text-box.

Expected Results:  
aligned to right
This is by design: see bug 298875
Component: General → Layout: Form Controls
OS: Mac OS X 10.3 → All
Product: Firefox → Core
Hardware: Macintosh → All
Version: unspecified → 1.0 Branch
Yeah, this was specifically done to be compatible with IE6 and Opera.
Marking INVALID and making it dependant on that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: Layout: Form Controls → Build Config
Depends on: 298875
OS: All → Mac OS X 10.3
Hardware: All → Macintosh
Resolution: --- → INVALID
Component: Build Config → Layout: Form Controls
OS: Mac OS X 10.3 → All
Hardware: Macintosh → All
Version: 1.0 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.