Find text in a textarea, then copy/paste text from outside the textarea

VERIFIED DUPLICATE of bug 334584

Status

Camino Graveyard
HTML Form Controls
VERIFIED DUPLICATE of bug 334584
12 years ago
12 years ago

People

(Reporter: Nep, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1

After find discovers text inside a textarea, it doesn't release the selection when you click outside the textarea. This interferes with the copy/paste of content after you find on a page.

Reproducible: Always

Steps to Reproduce:
Here's the scenario.  You have a page with text in a textare, and text outside the textarea.  You do a Find -- and you find the text inside the text area.  That text is now highlighted.

Now, you select some text outside the textarea.  You copy (Cmd-C).

Switch to another application, and paste.  You end up with the found text from the textarea.  The textarea's highlighting didn't go away when you selected some other text outside the text area, and the copy picked up the textarea selection, not your selected text.
Actual Results:  
You end up pasting the wrong block of text.

Expected Results:  
You should paste and get the block of text you had selected.
(Reporter)

Updated

12 years ago
Summary: Find text in a form, then copy/paste text outside the form → Find text in a textarea, then copy/paste text from outside the textarea

Comment 1

12 years ago
This is reproable when Cmd-G is part of the mix, so duping to bug 334584.

*** This bug has been marked as a duplicate of 334584 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.