A HREF="foo" TARGET="_self" messes up a TABLE

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: siking, Assigned: karnaze)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win95; en-US) Mozilla/m13
BuildID:    2000022820

I have a table, that contains only text.  Some of the text is a hyperlink, of
the form <A HREF="foo" TARGET="_self">.  This obviously involves frames too, but
the problem is with the TABLE.  When you click on this link, the cell in which
this text appears, gets "shifted" to the right.  A second click will actually go
to the specified page.
I do not know exactly which part of the code causes this (it is probably a
combination of tags), so I will include the code down below.


Reproducible: Couldn't Reproduce
Steps to Reproduce:
1.I will paste the code below
2.open it in a browser
3.click on one of the active links


Actual Results:  The table cell in which the link appears gets shifted to the right.

Expected Results:  The broser should go to the page specified by the link.


<HTML>
<HEAD>
<TITLE>PowerSuite</TITLE>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
</HEAD>

<BODY BGCOLOR="#FFffcc" TEXT="#000000" LINK="#cc0000" VLINK="#990000">
<H1 ALIGN="CENTER"><I><FONT COLOR="#6633CC">PowerSuite:</FONT></I></H1>
<H2 ALIGN="CENTER"><FONT COLOR="#6633CC">Verification Solution of Tomorrow,
Available
  Today</FONT></H2>

<TABLE BORDER="0" ALIGN="CENTER" NAME="Accelerators">
  <TR>
      <TD>&nbsp;</TD>

    <TD><IMG NAME="CoBALT" SRC="imgz/CoBALT_box.jpg" WIDTH="244" HEIGHT="180"
ALT="CoBALT box [21kB]" BORDER="0"></TD>
    </TR>
    <TR>

    <TD><IMG NAME="Radium" SRC="imgz/Radium_box.jpg" WIDTH="200" HEIGHT="299"
ALT="Radium box [6kB]" BORDER="0"></TD>
      <TD>&nbsp;</TD>
    </TR>
  </TABLE>
<H2 ALIGN="CENTER">Training Topics:</H2>
<TABLE BORDER="1" CELLSPACING="0" CELLPADDING="10" ALIGN="CENTER" WIDTH="75%"
NAME="topics">
  <TR ALIGN="center">
    <TD WIDTH="50%"><FONT SIZE="+2">Basic Training</FONT></TD>
    <TD WIDTH="50%"><FONT SIZE="+2">Advanced Training</FONT></TD>
  </TR>
  <TR ALIGN="center">
    <TD>
      <P><FONT SIZE="+1">Lecture One: <A HREF="01_background/01_overview.htm"
TARGET="_self">Background</A></FONT></P>
      <P><FONT SIZE="+1">Lecture Two: <A HREF="02_compiler/01_compiler.htm"
TARGET="_self">The
        Compiler</A></FONT></P>
      <P><FONT SIZE="+1">Lecture Three: <A HREF="03_debugging/01_runtime.htm"
TARGET="_self">Debugging
        and Testbenches</A></FONT></P>
    </TD>
    <TD>
      <P><FONT SIZE="+1">Verilog PLI</FONT></P>
    </TD>
  </TR>
</TABLE>
<P>The <I>Basic Training</I> topics should be covered in the order presented above.
  Each lecture should take approximately one day to complete. The <I>Advanced
  Training Series</I> can be covered in any order strictly based on the user's
  needs, each topic taking approximately one half of a day.</P>
<P>Please note: <I>topics which are not an active link are currently under, or
  planned for future development</I>.</P>
</BODY>
</HTML>

Updated

19 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

19 years ago
I'm not seeing the problem.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
Adding 'verifyme' keyword
Keywords: verifyme

Comment 3

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101014 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.