Unknown column 'blocked' in 'where clause' at globals.pl line 133

VERIFIED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
P3
normal
VERIFIED WORKSFORME
18 years ago
5 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: justdave)

Tracking

Details

(Whiteboard: 2.12, URL)

(Reporter)

Description

18 years ago
I got an unknown column 'blocked' in 'where clause' at globals.pl line 133
when doing the following query (using IE5, although I doubt that is why   
this time):

http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_sta
tus=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bu
g_status=VERIFIED&bug_status=CLOSED&resolution=WONTFIX&resolution=LATE
R&resolution=REMIND&email1=&emailtype1=substring&emailassigned_to1=1&e
mail2=&emailtype2=substring&emailreporter2=1&bugidtype=include&bug_id=
&changedin=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&short_desc
=&short_desc_type=substring&long_desc=&long_desc_type=substring&bug_fi
le_loc=&bug_file_loc_type=substring&status_whiteboard=&status_whiteboa
rd_type=substring&keywords=&keywords_type=anywords&field0-0-0=blocked&
type0-0-0=casesubstring&value0-0-0=7954&cmdtype=doit&order=Reuse+same+
sort+as+last+time
  
I'm only learning SQL, but I guess the problem is that the following:
   ..... AND (INSTR(blocked, '7954')) .....
...should have the "blocked" in quotes?

The full error message I got was:

Software error:
SELECT bugs.bug_id, bugs.groupset, substring(bugs.bug_severity, 1, 3), substring
(bugs.priority, 1, 3), substring(bugs.rep_platform, 1, 3), 
map_assigned_to.login_name, substring(bugs.bug_status,1,4), substring
(bugs.resolution,1,4), substring(bugs.short_desc, 1, 60) FROM bugs, profiles 
map_assigned_to, profiles map_reporter LEFT JOIN profiles map_qa_contact ON 
bugs.qa_contact = map_qa_contact.userid WHERE bugs.assigned_to = 
map_assigned_to.userid AND bugs.reporter = map_reporter.userid AND 
bugs.groupset & 0 = bugs.groupset AND (bug_status = 'UNCONFIRMED' OR bug_status 
= 'NEW' OR bug_status = 'ASSIGNED' OR bug_status = 'REOPENED' OR bug_status 
= 'RESOLVED' OR bug_status = 'VERIFIED' OR bug_status = 'CLOSED') AND 
(resolution = 'WONTFIX' OR resolution = 'LATER' OR resolution = 'REMIND') AND 
(INSTR(blocked, '7954')) GROUP BY bugs.bug_id ORDER BY bugs.priority, 
bugs.bug_severity: Unknown column 'blocked' in 'where clause' at globals.pl 
line 133. 
Please send mail to this site's webmaster for help.

Comment 1

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara

Comment 2

18 years ago
taking ownership and marking 2.12
Assignee: tara → cyeh
Whiteboard: 2.12

Comment 3

18 years ago
i just tried doing this query, and i didn't get an error. does this still happen 
for you?
(Reporter)

Comment 4

18 years ago
Hmm. WORKSFORME now except that it now shows bug 50714.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Target Milestone: --- → Bugzilla 2.12

Comment 5

17 years ago
Sorry for the spam, but I needed to be able to query for all of these correctly.
This is actually a duplicate of bug 30823, but it would be pointless to reopen 
now just to set the duplication.  It is fixed however.  Verif. worksforme.
clearning milestone on resolved non-FIXED bugs in case they ever get reopened.
Target Milestone: Bugzilla 2.12 → ---
moving all closed Bugzilla bugs to the new Bugzilla product.
This batch is DUPLICATE/INVALID/WORKSFORME/WONTFIX
reassigning to default owner and QA in case of the bug being reopened.
Clearing milestones, since we really shouldn't have them on these types of
resolutions.  Sorry for the spam everyone...
Assignee: Chris.Yeh → justdave
Status: VERIFIED → NEW
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
damn, bit by bug 30731. sorry for the respam...  one more coming to fix the status
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
fixing status...
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.