Closed Bug 337355 Opened 16 years ago Closed 11 years ago

Report a Broken website link on b.m.o isn't very helpful

Categories

(bugzilla.mozilla.org :: General, defect, P1)

Tracking

()

RESOLVED FIXED

People

(Reporter: gidsgoldberg, Assigned: glob)

References

()

Details

Attachments

(1 file)

I think there's a couple of issues here:

1. "To report a broken website, first please make sure that you are running the latest developer release of Firefox." 

Is it really so bad that users report broken websites in the latest stable verion; they certinally shouldn't be discouraged from doing so, after all we want developers to make sites work in the latest version that has shipped.

2. The link 'latest developer release' links to http://www.mozilla.org/projects/firefox/ a page which currently offers little aid to a user trying to test the latest version of Firefox unless they are willing to compile it from source, how exactly is the user supposed to know to click on Nightly Builds to get what they are after?

None of these issues are deal-breakers but the point is; I think the page could be improved.
Hmm, yeah, that page was written when you needed a development release to get the broken website tool.  It's available in production releases of Firefox now, so we don't need to say that anymore.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hmm, suppose I should ask Robert how he wants it worded. :)
Robert: ping
Sorry for the delay, this fell off the radar.

I guess something to the effect of:

"To report a broken website using Firefox 1.5 or later, visit the problematic site, then in the 'Help' menu select 'Report Broken Website'" 

Since Firefox 1.x support is dying... no need to even mention that.  I guess just explicitly state Firefox 1.5 should be used.
Priority: -- → P1
QA Contact: myk → reed
Rearranging this component to not have me as the default assignee, so that it doesn't appear like I'm intending to work on bugs that other people could be taking care of if they didn't think I was already doing them.  If this bug is a software issue on b.m.o and you'd like to fix it, the modified source is now available for the patching (see bug 373688).  Reassigning to the new default owner.
Assignee: justdave → nobody
QA Contact: reed → other-bmo-issues
As of Firefox 4, people will be reporting broken websites via the Input tool: http://input.mozilla.org/

Gerv
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
(In reply to comment #6)
> As of Firefox 4, people will be reporting broken websites via the Input tool:
> http://input.mozilla.org/

Then somebody should fix the page.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
True :-) The latest version of Input hasn't shipped yet (due in January) but when it does, we should fix Bugzilla up to point to it.

Gerv
how about replacing all links to https://bugzilla.mozilla.org/page.cgi?id=broken-website.html with http://input.mozilla.com/feedback ?
Status: REOPENED → NEW
simple patch to replace broken-website with input-feedback
Assignee: nobody → bjones
That page gives you a nasty "go away" warning if you're not running Firefox 4.
In fact, it gives *me* that go away warning and I'm on trunk nightlies (which are essentially Firefox 4 at this point).
Yeah we can't send people there til that message changes. I imagine that will be after ff4 is released.
i asked aakashd about this.. that's the correct url to direct people to, and it won't accept feedback from nightlys "for another month or two".
Blocks: bmo-upgrade
Status: NEW → ASSIGNED
Duplicate of this bug: 629647
ok, i'm going to push this to 3.6 and 4.0.

while input doesn't accept feedback from nightly builds, the "submit feedback" option in those builds go to the input/feedback url so it's definitely correct.
Duplicate of this bug: 512880
fixed on 3.6 branch and 4.0
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.