Spell Dictionary not recognized if the filename of the dictionary .aff and .dic include a foreign (accented) character

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: cara_lho2001, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050921 Firefox/1.0.7
Build Identifier: thunderbird-win32-1.5.0.2-2006-04-20-04-mozilla1.8.0.zip

I've had several dictionaries, and I set the filenames of their .aff and .dic files to show the actual names of the languages, rather than coded abbreviations (like PT-BR, etc...).
Examples of these are Português, Español and Français.
The problem is that neither spell_as_you_type nor manual spelling were working properly, not recognizing common words (they did work in TB 1.0.8, which did not have spell_as_you_type).
Curiously, I found that if I set the dictionary to Brasileiro (Brazilian, my filename for PT-BR), then nearly all words written in Portuguese (PT-PT) were successfully recognized, as they should be.
The brainstrom was considering the possibility of the actual naming of the dictionary files as being the problem.
And sure enough, when I changed those names I gave in the example to Portugues, Espanol and Francais (i.e., removing/substituting the accented characters), then the Portuguese dictionary works just fine, and so does the Spanish, etc...

Reproducible: Always

Steps to Reproduce:
1. Cause a dictionary's .aff and .dic filenames to include an accented character, as for instance Español for the Spanish dictionary.
2. Choose that dictionary for TB's spelling.
3. Create an e-mail msg written in Spanish.

Actual Results:  
After the described set-up, the user will find that spell-checking does not recognize common Spanish words.

Expected Results:  
One would naturally expect that spell-checking would only flag misspelt words, and not properly spelt common words.

4. Close Thunderbird.
5. Change the test dictionary's .aff and .dic filenames to Espanol (changing the accented character to plain 'n').
6. Create a new e-mail msg or test against the already written one.

7. The user will find that the spell-checking now works as expected.

Updated

12 years ago
Component: Message Compose Window → Spelling checker
Product: Thunderbird → Core
QA Contact: spelling-checker
Version: unspecified → 1.8 Branch
> I've had several dictionaries, and I set the filenames of their .aff and .dic
> files to show the actual names of the languages, rather than coded
> abbreviations (like PT-BR, etc...).

Where exactly do you set these file names? Why change the file name?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> > I've had several dictionaries, and I set the filenames of their .aff and .dic
> > files to show the actual names of the languages, rather than coded
> > abbreviations (like PT-BR, etc...).
> 
> Where exactly do you set these file names? Why change the file name?

The filenames are originally two-letter groups (as EN-US, etc...).
The dictionary ("Language") names shown by the TB Spell Checker in the drop-down list are the names of the files.
I find it a bit ugly, and also more complicated for other (at home) users of my PC to have to know which set to choose.
So I've always changed the filenames, under Windows (simple file rename), to the real names of the languages.
That way, the drop-down list shows the actual names of the various languages.
In three of the languages I use, the REAL name needs to be written with 'accented' characters (Français is an example which I think everybody knows...)
There was no problem whatsoever with this in TB 1.0.8
Problem began with the 1.5.x generation, and I narrowed it down to the presence of at least one 'accented' character within the name, which is a bug, as it all works fine under the go-around procedure, which is, for instance, to call the French dictionary files 'francais' rather than using the correctly spelt name.
OK, so it may not be part of the spec, but it sure is nicer for multi-lingual individuals and locations to be able to see the name of their languages spelt properly, no?
Tried with a nightly 2.0 build? 
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/

(You need an updated dictionary, an old one still says install ok, but won't work, see bug 343901)

Comment 4

12 years ago
(In reply to comment #3)
> Tried with a nightly 2.0 build? 
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/
> 
> (You need an updated dictionary, an old one still says install ok, but won't
> work, see bug 343901)

Magnus, this bug predates your regression report for 2006062903 
Yes, I know. But after the change that caused that, all kind of the firefox spell checking fixes were made. So it might be worth checking a newer build...

(I was just pointing out you need an updated dictionary to test...)
(Reporter)

Comment 6

12 years ago
(In reply to comment #3)
> Tried with a nightly 2.0 build? 
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/
> 
> (You need an updated dictionary, an old one still says install ok, but won't
> work, see bug 343901)
> 
No, I haven't tried it, because the relevance of this isn't worth my time.
But if the problem appears when the FILENAME of the dictionary contains characters >=ASCII 128, why would an updated dictionary work?
Assignee: mscott → nobody

Comment 7

10 years ago
Works for me on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)

I renamed fr-FR.dic and .aff in the mozilla firefox\dictionaries directory to Français, and not only does it work but the proper name (Français) even shows up in the dictionary switcher addon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

9 years ago
Good grief.
I reported the bug re. THUNDERBIRD!

Magnus Melin understood it was Thunderbird, but at one point he changed course and started pointing to Firefox...
And then M. Caywood says WFM re. firefox\dictionaries... (2009-06-17)

I say again: THUNDERBIRD.

This better be reopened and checked by somebody different, no offense.

Comment 9

9 years ago
Hi C. Coimbra. If you can report this fails with version 3 thunderbird we can reopen the bug. It uses the same spellchecker as M Caywood tested in comment 7
You need to log in before you can comment on or make changes to this bug.