Deleting an IMAP Inbox should not be allowed

VERIFIED DUPLICATE of bug 33235

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 33235
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: jefft)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2000-03-28-09M15: NT4, Linux 6.0
Can't try Mac right now.

Overview: Deleting an IMAP Inbox should not be allowed.

Steps to reproduce: 
1. With an IMAP Inbox selected, click onto the Delete button.
2. * The Inbox disappears and does not reappear anywhere in the Folder pane. 
Check the Trash folder and it doesn't appear there, not even as a subfolder.
3. Close and restart Mail.
4. * Select the account level and Get Messages and nothing happens.
5. Select any folder in the account and the password dialog now appears.
6. Enter the password and a new Inbox is created but it doesn't have any 
messages, since the original Inbox is now in the Trash folder.
7. Go to the Trash folder and now you can see the Inbox as a subfolder.
8. Select File|Empty Trash and the old Inbox folder and its messages are 
removed.

Expected Results:
Item#2: Some type of dialog should appear stating that deleting the Inbox folder 
is not allowed. 
Item#4: In any case, when selecting the account level and getting messages the 
password dialog should display. I should't have to select a folder (i.e. Drafts) 
to be prompted. Normally after selecting the account level and selecting Get 
Messages the Password dialog does appear but in this case it doesn't.

Additional Information:
- NT4: Tried deleting a POP accounts Inbox folder and it displays a window 
asking "Are you sure you want to move the selected folder into the Trash?". 
Select "OK" and the Inbox is not moved but remains in its place along with its 
messages.
(Reporter)

Comment 1

18 years ago
Assigning to huang since she's testing IMAP and folders.
Assignee: selmer → putterman
QA Contact: lchiang → huang

Comment 2

18 years ago
reassigning to jefft.  Jeff, I don't know if you filed this bug already since
we'd talked about this.
Assignee: putterman → jefft
(Assignee)

Comment 3

18 years ago
Yes, bug 33235.

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 33235 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verified as duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.