The user prefs tab let you change the password and email address of a user being impersonated when using the ENV method (with user_info_class="Env,CGI")

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
User Accounts
--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Frédéric Buclin, Assigned: Max Kanat-Alexander)

Tracking

({regression})

2.23
Bugzilla 3.0
regression
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment)

v1
653 bytes, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
From bug 300410 comment 24:

The user prefs tab, userprefs.cgi?tab=account allows you to change the password and email address of a user being impersonated when using the ENV method with
user_info_class="Env,CGI". This doesn't happen if you are not impersonating someone. Looks like the Auth system is confused in this case.
(Assignee)

Comment 1

12 years ago
Created attachment 221806 [details] [diff] [review]
v1

Ah, also an easy one. The sudo target didn't have a Bugzilla::Auth object set, so it was just acting like a logged-out user. :-)
Assignee: user-accounts → mkanat
Status: NEW → ASSIGNED
Attachment #221806 - Flags: review?(LpSolit)
(Reporter)

Comment 2

12 years ago
Comment on attachment 221806 [details] [diff] [review]
v1

Nice catch! r=LpSolit
Attachment #221806 - Flags: review?(LpSolit) → review+
(Reporter)

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+
(Reporter)

Comment 3

12 years ago
Checking in Bugzilla.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla.pm,v  <--  Bugzilla.pm
new revision: 1.32; previous revision: 1.31
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.