@defaultdomain autocomplete is very annoying and should be an option

RESOLVED DUPLICATE of bug 326280

Status

--
enhancement
RESOLVED DUPLICATE of bug 326280
13 years ago
13 years ago

People

(Reporter: darkmagess, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060503 Flock/0.5.15.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060503 Flock/0.5.15.0

Automatically defaulting to autocompleting and address with my own domain is very annoying. I'm the only person on my domain. Why should anyone else's address ever autocomplete to that? I could see it being useful for a business, but I'm not a business. Why would a home user ever need such a feature unless they happened to be using AOL? Can you please make this an option. It should only autocomplete to addresses that it actually has information about. This behavior is especially annoying when you're trying to paste and address that's been written out "me at this dot com" and replace the words with symbols, because it insists on appending useles things while you're trying to edit.

Reproducible: Always

Steps to Reproduce:
1.start typing address in To: field
2.address isn't in address book
3.autocompletes to my domain, which is incorrect



Expected Results:  
I would like it to not autocomplete anything if it doesn't find a matching string.

Comment 1

13 years ago
There's a preference mail.identify.default.autocompleteToMyDomain that can be set to false per identity. But the default in Thunderbird 1.5 is supposed to be false.

You can change the preference manually in the Options (Advanced->General->ConfigEditor) ; there's no Gui for it yet.

*** This bug has been marked as a duplicate of 326280 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.