New bookmarks file being created every few seconds - eats processor time and disc space

RESOLVED DUPLICATE of bug 294584

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 294584
12 years ago
12 years ago

People

(Reporter: Phil Faber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Sharing bookmarks file over a network (via locked bookmarks.html alias).  Sometimes Firefox runs happily for hours with no problems.  Other times it starts constantly attempting to overwrite the locked bookmarks.html file, creating hundreds / thousands of copies (fresh copy every 10 - 15 seconds).  Brings the computer to a grinding halt and eats up all available disc space.

Reproducible: Sometimes

Steps to Reproduce:
Have tried everything we can think of, but this fault seems to  be entirely random!  Have tried (for example) running / quitting other programs, adding a bookmark to the Network Administrator's orginal bookmarks.html file.  No idea what combination of circumstances is causing this.



Suggest problem is Firefox is repeatedly trying (under some circumstances) to overwrite the locked bookmarks.html file.  

Suggested fix: Firefox on opening should check to see whether bookmarks.html is a locked file.  If it is, Firefox should NOT attempt to overwrite it.  If network user attempts to add a bookmark, message box stating "The bookmarks file is locked.  Send a request to your Network Administrator to add this bookmark to the shared bookmarks file."  (This would have the added-bonus side effect of possibly deterring computer misuse in work situations!)

Comment 1

12 years ago
Upgrade to Firefox 2 for the fix for this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 294584
You need to log in before you can comment on or make changes to this bug.