"mails received" traybar popup does not follow/understand message filters

RESOLVED DUPLICATE of bug 228168

Status

RESOLVED DUPLICATE of bug 228168
13 years ago
13 years ago

People

(Reporter: michael.noisternig, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Thunderbird does neither count in messages moved to a different mailbox (e.g. local folder) via a message filter nor does it understand where the messages have gone.
See steps to reproduce.

Reproducible: Always

Steps to Reproduce:
1. receive mails that are all moved to different mailbox (e.g. Local Folders) via message filter -> traybar popup says "0 mails received"
2. click on Local Folders' inbox to read mails -> traybar popup does not disappear
3. click on (empty) original mailbox' inbox folder (the mailbox where messages are checked from) -> traybar popup disappears



Expected Results:  
- traybar popup should display # received messages *before* they are moved via message filters, or otherwise display moved messages as well as new
- traybar popup should follow where message have gone

Comment 1

13 years ago
(In reply to comment #0)
> 1. receive mails that are all moved to different mailbox (e.g. Local Folders)
> via message filter -> traybar popup says "0 mails received"

Bug 228168 (only applies to IMAP, POP filtering counts correctly).  
See also bug 138631, which applies to all types of accounts.

> 2. click on Local Folders' inbox to read mails -> traybar popup does not
>    disappear
> 3. click on (empty) original mailbox' inbox folder (the mailbox where
>    messages are checked from) -> traybar popup disappears

Bug 116181 / bug 222068 / bug 272328 / bug 313694 / bug 292120 and probably a few others I haven't noted down are all about, basically, this same problem: 
all "new mail" indications persists until some action (read a new message or select a folder) is taken within the folders of the original receiving account (or one of the original receiving accounts, if there are several).  Don't be mislead by the fact that some of those bugs are filed for the suite and some 
for TB -- the fix, if there ever is one, will be in the backend and will affect both programs.

This bug is about two symptoms; you should pick either bug 116181 or bug 228168 and mark this as a dupe of that one.
(Reporter)

Comment 2

13 years ago
Maybe it's two symptoms but I'd say they have one cause (thunderbird not following message filters). If you want this report to be classified as a dup please choose one on your own. (I'd suggest bug 228168 but I think you are more qualified to make a decision.)

Comment 3

13 years ago
That's my pick as well.

*** This bug has been marked as a duplicate of 228168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.