raja-antura.org - Content-Encoding: non

RESOLVED INCOMPLETE

Status

Tech Evangelism Graveyard
Other
RESOLVED INCOMPLETE
12 years ago
3 years ago

People

(Reporter: laulumaa, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a1) Gecko/20060513 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a1) Gecko/20060513 Minefield/3.0a1

While trying to view discussion forum I get following error message: 

Content Encoding Error

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression. Please contact the website owners to inform them of this problem.


Reproducible: Always




I'm using Gentoo and same problem is on both my Gentoo computers (32-bit and 64-bit). I'm using latest Minefield build. I'm not using build compiled on my own.
How is this a bug in Firefox? The server hosting the site is most likely sending the content out with bad compression or encoding.
If you can prove that the server is sending it out with perfectly correct encoding and compression, _then_ it is a bug in Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
The encoding and compression may not be perfectly correct, but it is evidently good enough for 1.8 branch builds because Bon Echo Alpha 2 can handle the page just fine.
So it works in Bon Echo a2, but not on trunk? Reopening. :-(
Reporter, could you collect some information about the server? The markup which is actually being sent and the headers would be good.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

12 years ago
I have limited access to this server (webhotel, I'm the admin of this site) where this "feature" has occured. Only mindfield users have told me about this error, so I really don't know weather it is a bug in our software or in mindfield. But anyway, heres some info about headers (curl -I):

tuxu@localhost ~ $ curl -I http://www.raja-antura.org/index.php?option=com_smf&Itemid=36
[1] 30016
tuxu@localhost ~ $ HTTP/1.1 200 OK
Date: Sun, 14 May 2006 12:35:08 GMT
Server: Apache
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Content-Encoding: non
Expires: Mon, 26 Jul 1997 05:00:00 GMT
Pragma: no-cache
X-Powered-By: PHP/5.0.4
<-- Cookie info cut off-->
Last-Modified: Sun, 14 May 2006 12:35:08 GMT
Content-Type: text/html; charset=ISO-8859-1

If you need some specific information about the server/php, please inform me about it and I'll try to provide the info you need. 
As far as I know (and as far as http://www.iana.org/assignments/http-parameters tells me), the value "non" for Content-Encoding is completely invalid, thus the error message Minefield produces is completely correct, and it is earlier versions of Firefox which are at fault (they probably just ignore the error).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID

Comment 6

12 years ago
(In reply to comment #5)
> As far as I know (and as far as http://www.iana.org/assignments/http-parameters
> tells me), the value "non" for Content-Encoding is completely invalid, thus the
> error message Minefield produces is completely correct, and it is earlier
> versions of Firefox which are at fault (they probably just ignore the error).

Alternatively this could be moved to Tech Evang.
Good point.
Status: RESOLVED → UNCONFIRMED
Component: General → Other
Product: Firefox → Tech Evangelism
Resolution: INVALID → ---
Summary: Content Encoding Error when trying to view page → Content-Encoding: non

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Content-Encoding: non → raja-antura.org - Content-Encoding: non
Assignee: nobody → other
QA Contact: general → other

Comment 8

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 12 years ago8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.