After downloading rest of truncated message, it disappears

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: S.W.B., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/20060405 SeaMonkey/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/20060405 SeaMonkey/1.0.1

Hi, I use Thunderbird 1.5 on Ubuntu Breezy, and I download my Gmail over POP3
with a SLOW 28k dialup connection.  I have enabled the 50k message size
limitation.  When I get larger messages, SeaMonkey downloads a shorter version,
with the message 
"Truncated! This message exceeded the Maximum Message Size set in Account
Settings, so we have only downloaded the first few lines from the mail server.
Click here to download the rest of the message."

However, when I click to download the full message, it downloads for about 10
minutes (1 or 2 MB message) and then the message disappears.  That's it.  Gone.
 It's still there when I access Gmail via web interface, but I can't get to it
at all from Thunderbird.  Please note that this occurs every time I
download messages larger than a certain size, which I haven't yet identified. 
All I can say is that a 60KB message came through fine, as did a 468KB message,
but a 1600KB and a 2200KB message disappeared.  Note that the message is not getting flagged as Junk mail, because the sender is in my address book, and I don't have Junk mail deletion enabled, it would just turn on the flag if it thought the message was junk.  I don't have any filters at all.  Also note that SeaMonkey 1.0.1 behaves in exactly the same manner.  This appears to be a long standing bug that has occurred ever since 2002 versions of Mozilla, with various POP3 providers.  Not just a Gmail issue, or Thunderbird 1.5 issue.  See: https://bugzilla.mozilla.org/show_bug.cgi?id=225199 ; https://bugzilla.mozilla.org/show_bug.cgi?id=118432 ; https://bugzilla.mozilla.org/show_bug.cgi?id=141152

Reproducible: Always

Steps to Reproduce:
1.Email to your Gmail account a message with 2MB worth of JPEG's
2.Set size limitation to 50K
3.Set your connection speed VERY slow, i.e. 28kbps
3.Get new mail
4.Click on "download entire message"


Actual Results:  
The 2MB message will disappear

Reproducible: Always

Comment 1

12 years ago
Hi, I have a very similar problem using Thunderbird 1.0.2 on Linux (haven't tested newer versions yet).

I use a freemail account (freemail.web.de) which has a special limitation concerning time between POP3 accesses, so sometimes the POP server will refuse to handle requests.
The password for this account is not stored within TB, so I have to enter it when checking mail (normally just the first time in a session).

These are (some of) my account settings:
size limit 300kb.
secure connection (SSL): yes
secure authentication: no
automatically download new messages: yes
fetch headers only: no
leave messages on server: yes
for at most: 20 days
until I delete them from my inbox: no

-------


When I receive a partially downloaded message ("click here to download the rest of the message") and try to download the message, one of the following things may happen:

a) it will simply download without problems, no dialogs appearing

b) TB will ask for the password again (even though it has already been entered), then the message downloads.

c) (this has happened twice recently) TB will ask for the password, apparently starts to download but immedeatly stops again. The message disappears from the message list, but the "click here to download the rest of the message" message is still visible in the text window until I select another message.
If I try to click on the download link again, nothing happens.
The message is (apparently) still on the server, at least visible in webmail.

The message sizes were 548K and 1100K. Both had several MIME attachments but not HTML.
I believe that the problem occurs when the POP3 server denies a request due to its timing restrictions.

The JS console shows the following, probably (!) related to event c) above:
(note, I xxxed out the email adress for spam protection)

Error: uncaught exception: Load of pop://xxxxx@pop3.web.de:995/?uidl=565004509 denied.

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMessenger.messageServiceFromURI]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: SelectMessage :: line 1605"  data: no]
Source File: chrome://messenger/content/msgMail3PaneWindow.js
Line: 1605

Error: uncaught exception: Load of pop://xxxxx@pop3.web.de:995/?uidl=565004509 denied.

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMessenger.messageServiceFromURI]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: SelectMessage :: line 1605"  data: no]
Source File: chrome://messenger/content/msgMail3PaneWindow.js
Line: 1605

Error: uncaught exception: Load of pop://xxxxx@pop3.web.de:995/?uidl=565004511 denied.

-----

Steps to reproduce:
1) create a freemail.web.de account (FREE account with POP3 time limit)
2) setup TB for this account. Do NOT store the password in TB.
3) set download size limit to 300k (or other smallish size)
4) send a large email (exceeding the limit) to the account
5) check mail with TB (enter password)
6) click to download the rest of the message. Enter password again if asked.

Actual Results:
does not download, message disappears (Sometimes!)

Expected Results:
TB does not ask for password again, downloads message.
If server denies download, displays a message and lets user try again later.

Reproducible:
Only sometimes! May depend on timing between steps 5 and 6. Try several times.

-----

A note aside, though this may be another bug: when the download of a partial message is aborted (e.g. by pressing ESC), it is impossible to restart the download afterwards (ie. nothing happens when clicking the link). This is reproducible. I think that restarting TB helps, but I have to check again.
QA Contact: front-end

Comment 2

11 years ago
does this sound to you like a dupe of bug 265553?

Comment 3

10 years ago
^^
Assignee: mscott → nobody

Comment 4

10 years ago
If the mail has been deleted from the server, then clicking on the full download link will make the message disappear. The other common cause of this is the junk mail control deciding that the fully downloaded message is junk, and moving it to the junk folder.

But, we've fixed a lot of problems since TB 1.02, so I'd suggest trying a newer version.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 5

10 years ago
STEPS TO REPRODUCE:
- using a http://freemail.web.de freemail account (a popular freemail provider in germany)
- using the option "do not download messages larger than XX kB" (5kB is good
for reproducing) OR "download headers only"
- immediately downloading the rest of all truncated messages without waiting
for the POP3 poll time limit to expire (web.de freemail accounts: 15min) 
RESULT: DATALOSS (the first message may be retrieved correctly, but all others 
are gone / they disappear completely)

using thunderbird 2.0.0.14 (nothing changed since 1.0.3 :-( )

reproducible: always
severity: MAJOR / CRITICAL

duplicates of this bug: bug 118432, bug 225199, bug 275594, bug 322710, bug 337950, bug 362361, bug 368404, bug 265553
You need to log in before you can comment on or make changes to this bug.