Replying on secondary account places reply at the bottom of the quote and omits signature

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: andrew.emery, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

I have two email accounts set up. The primary account replys flawlessly with the reply above the quote and the signature place below the reply (above the quote). The secondary account always places the reply at the bottom of the quote and omits the signature regardless of the settings through "Composition and Addressing". This feature worked fine in version 1.0 and 1.07  but when I upgraded to 1.5 and later 1.502 the bug appeared. I have tried all the stated methods to remedy it (new profile, uninstalling previous versions (heck I even deleted every thunderbird directory and file except my backup profile once to see if that would work). It is only corrected if I re-install version 1.07. This is similar to a number of bugs I have searched for but extends it with the absence of the signature.

Reproducible: Always

Steps to Reproduce:
1.Create multiple accounts
2.Receive email into secondary account
3. Attempt to reply with a signature attached and the reply above the quote
4. Check to see that the correct options were set in the secondary account settings.

Actual Results:  
Reply placed at the bottom of the quoted text with no signature

Expected Results:  
Reply appears above the quote and there is a signature (complete with ------ would be good)

Comment 1

13 years ago
Reporter, the settings for replying above and below, can be set differently per account. See Account Settings->Composition
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Reporter, the settings for replying above and below, can be set differently per
> account. See Account Settings->Composition
> 

That is true (and has been done) but the reply is always placed at the bottom of the quote (and the signature absent) regardless of the setting on the second account.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5

Comment 3

12 years ago
The problem of the caret being placed after the quote (regardless of setting) when you change identity is bug 118050.

Signature settings are actually per-identity, not per account.  The account settings UI exposes these settings for the primary identity; if you have a second identity defined under an account, you need to use the Manage Identities button to make changes at that level.

Andrew Emery, does this apply to your situation?  With identities set up correctly, I can't reproduce the problem of the sig being omitted when the identity changes.

See also bug 218346.

Comment 4

12 years ago
No response from reporter  =>  WorksForMe
Andrew, feel free to reopen, but provide a response to comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.