Master password will not work after three months of use

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
12 years ago
10 years ago

People

(Reporter: melfanie, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

I've done this several times and on several different computer systems with the same result. After establishing a master password to lock up all of my other passwords, I first noticed about 6 months ago that it will stop working after exactly three months. Even if the correct master password is entered, it will keep asking you to re-enter the password. It happened on both computer systems in my home, two at a friends house and my father's. The password I used was written down in a journal and I also emailed it to myself to be sure that I just wasn't making an error, but the correct password does not work. Because of this I am no longer able to load any of my passwords, remove the master password or save additional passwords. 

Reproducible: Always

Steps to Reproduce:
1. Install Firefox and save a password. Create a master password and write it down.
2. Keep using Firefox and saving passwords - wait exactly three months.
3. On the three month anniversary of the date that the master password was activated, it will no longer work.

Actual Results:  
My Master password, which I know I have not forgotten, simply stopped working. When I enter it in, the box will pop right back up and ask me for it again. And again.

Expected Results:  
It should have entered the username and password for the visited site into the field.

Updated

12 years ago
Group: security
Keywords: dataloss
There's really no mechanism by which this could be happening, we don't have any "three month" timers in the product. I am completely mystified that this happens to you not just one one computer but on several, and yet I've never heard of anyone else with this problem.

This problem is likely to remain unresolved unless we can figure out what all the computer you use have in common that is different from every other computer. The obvious commonality is you yourself: are there things you do every three months to your computer? backups? defragmenting the disk? installing or uninstalling things? Have you checked that the "caps lock" key is not on? (I hit caps lock accidentally a lot when reaching for the tab key)

We need more clues to what's going on, I strongly urge you to try the user support groups listed at http://www.mozilla.org/support/ -- the MozillaZine forums are good. You can find out if anyone else is having the same problem, and by process of elimination we can figure out what's special about your computers (a combination of plugins or extensions? some other software? certain preference settings?) that is a crucial part of this problem. Only when we figure that out will we have any hope of fixing it.
(Reporter)

Comment 2

12 years ago
The PC I'm using now is a new one (Acer), purchased on 2/2/2006. I installed Firefox on 2/11/2006 - it konked out on 5/11/2006. The other computer in my house, also a PC (Dell) with the same OS (Win XP w/ SP2). My The problem also occured on an HP, but I'm not sure of the other two brand names. I thought that I'd simply forgotten the passwords until it happened again... and it can not be just a case of a forgotten password. I have it commited to memory, written down and saved in my email, and I checked the caps key. I have not recently installed any software, nor have I defragmented, formatted or anything... I actually uninstalled FireFox in hopes that I could get rid of the prompt, but apparently uninstalling doesn't get rid of the saved password files. The only thing that I can think of having occured this most recent time is that my subscription to Norton Antivirus expired on the same day as the password failure. 

Comment 3

12 years ago
Set a master password, then try changing your computer's date clock in the Date and Time control to 2 months and 29 days ahead.  Then wait 3 days.  Does that make the passwords expire?

Comment 4

12 years ago
(In reply to comment #2)
> ... my
> subscription to Norton Antivirus expired on the same day as the password
> failure. 

I assume that's probably just a coincidence.  Do you guys agree with me?

Updated

11 years ago
Blocks: 382734
There is no real way that we can test for something that happens every 3 months.  Since the bug reporter has not commented on this bug in over a year (2006-05-15), I am going to assume that this is no longer an issue.

If this is still an issue, try upgrading to a more recent version of Firefox.  If this bug is still not resolved after that, please re-open the bug so we can revisit this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

11 years ago
No - it isn't that this bug isn't an issue anymore. I just haven't dared to set a Master Password since no one could explain why it stopped working so many times. I just use passwords elsewhere on my computer now, and all is good.(In reply to comment #5)


> There is no real way that we can test for something that happens every 3
> months.  Since the bug reporter has not commented on this bug in over a year
> (2006-05-15), I am going to assume that this is no longer an issue.
> 
> If this is still an issue, try upgrading to a more recent version of Firefox. 
> If this bug is still not resolved after that, please re-open the bug so we can
> revisit this.
> 

If you have not tried already, please update to 1.5.0.12 or upgrade to 2.0.0.4 and see if this fixes your problem.
verified with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a8pre) Gecko/2007083005 Minefield/3.0a8pre ID:2007083005

Master password works since a long time (longer than 3 months) and i have not seen this issue before.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.