browser.formfill.enable = false, disables search suggest

RESOLVED FIXED in Firefox 2 beta1

Status

()

--
major
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Peter6, Assigned: mozilla)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2 beta1
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060515 Minefield/3.0a1 ID:2006051512 [cairo]

repro:
1. go to about:config and set browser.formfill.enable to false
2. type anything in the searchbar (use Yahoo or Google)

result:
suggest is disabled
(Reporter)

Comment 1

13 years ago
same problem on 1.8.1 branch of course
Version: Trunk → unspecified

Comment 2

13 years ago
"set browser.formfill.enable to false" is same as
tools>Options>Privacy "Saved Forms"
uncheck "Save information..."

Comment 3

13 years ago
As I said in http://forums.mozillazine.org/viewtopic.php?p=2266185, suggestion wasn't working here (with browser.formfill.enable = true). I changed <SuggestionURL>http://www.google.com/complete/search?csv=t&amp;qu=</SuggestionURL>
to <SuggestionURL><![CDATA[http://www.google.com/complete/search?csv=t&qu=]]></SuggestionURL>
into google.xml (and made similar changes into yahoo.xml) and now it works.
(Reporter)

Comment 4

13 years ago
I think it is fundamentally wrong that a user is forced to store his formfill data if he wishes to use suggest.
Flags: blocking1.9a1?
Flags: blocking-firefox2?
(Assignee)

Updated

13 years ago
Assignee: nobody → joe
(Assignee)

Comment 5

13 years ago
This seems to be the relevant code that's causing this:
http://lxr.mozilla.org/mozilla1.8/source/browser/base/content/browser.js#1228

This is because the search suggestions are implemented using the same autocomplete interface that the form history uses.
Blocks: 335435
Status: NEW → ASSIGNED
+ for now until we decide what we're doing here.
Flags: blocking-firefox2? → blocking-firefox2+
*** Bug 340225 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Firefox 2 beta1
Comment on attachment 225086 [details] [diff] [review]
Disables search history (but preserves suggestions) when form history is disabled

So I was a little bit confused as to why this fixes this bug, but I realized that it works because both nsFormHistory::AddEntry (called to save text in form history after it is entered) and nsFormHistory::AutoCompleteSearch (called to get autocomplete entries from form history when building the popup) already check formfill.enabled and behave accordingly. This means that you can also remove the attribute check at:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/search/content/search.xml&rev=1.67&mark=393#392

r=me with that.
Attachment #225086 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 10

13 years ago
Attachment #225086 - Attachment is obsolete: true
Attachment #225296 - Flags: approval-branch-1.8.1?(mconnor)
Attachment #225296 - Flags: approval-branch-1.8.1?(mconnor) → approval-branch-1.8.1+
Version: unspecified → 2.0 Branch
(Assignee)

Comment 11

13 years ago
Landed on branch & trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Reporter)

Comment 12

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060615 Minefield/3.0a1 ID:2006061515

verified fixed on trunk

Comment 13

13 years ago
FYI, as a resource:

http://www.loconet.ca/
GSuggest extension
Flags: blocking1.9a1?
You need to log in before you can comment on or make changes to this bug.