PC crash corrupts Firefox bookmark files

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
5 years ago

People

(Reporter: carolyn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

This happened today, and once in the past to me.

Twice when PC has unexpectedly suffered a total crash or abrupt poweroff while I was doing nothing but had Firefox open, on the next boot Windows had to veridy files and folders and reported a problem with the initial blocks of Firefox bookmark files and then had to truncate them.  Only these files had a problem.

Does Firefox keep the bookmark files or profile open for write at all times?

Carolyn

Reproducible: Didn't try




I cannot purposely make my machine crash and I don't want to power offmy system abruptly.  But this has happened to me twice with different versions of Firefox.

Updated

12 years ago
Whiteboard: DUPEME

Comment 1

12 years ago
My PC at work crashed yesterday as I was manually closing programs to shut down my computer. The last open window was firefox (v. 1.5.0.6), and after closing one tab, I clicked the X to close the program, when I got the BSOD. This morning, all the bookmarks and search engines were gone.  Thankfully, I had a backup of my bookmarks from a couple of months ago. I'm going to uninstall and reinstall Firefox to make sure everything is clean.

Gala
Can you take a look at http://kb.mozillazine.org/Lost_bookmarks 
Maybe these steps there could help.

Comment 3

12 years ago
wrt bsod, please follow steps from bug 321723 comment 8

Comment 4

12 years ago
(In reply to comment #2)
> Can you take a look at http://kb.mozillazine.org/Lost_bookmarks 
> Maybe these steps there could help.
> 

Yep, this fixed it. Thanks all. Gala

Resolved wfm because of comment #4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.