xml processing with xsl: "xml-stylesheet" processing instruction's "media" pseudo-attribute doesn't seem to work

RESOLVED DUPLICATE of bug 210460

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 210460
12 years ago
12 years ago

People

(Reporter: Mirko Klemm, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

If I want to display an XML document with two related XSL stylesheets, one for media="print" and another one for media="screen", only the media="screen" processing instruction pseudo attribute seems to be processed.
Code example:

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet version="1.0" media="print" href="printstyle.xsl" type="text/xsl"?>
<?xml-stylesheet version="1.0" media="screen" href="screenstyle.xsl" type="text/xsl"?>
...




Reproducible: Always

Steps to Reproduce:
1. Create an XML file and two related XSL stylesheets
2. Link the two XSL stylesheets with the XML document using two processing instructions as recommended by w3c recommendation "http://www.w3.org/1999/06/REC-xml-stylesheet-19990629"
3. Open the XML document in firefox
4. Open the "Print Preview" from the "File" menu

Actual Results:  
The "Print Preview" renders the XML document formatted with the media="screen" stylesheet.


Expected Results:  
Opening the "Print Preview" in Firefox should render the document formatted with the media="print" stylesheet.

Haven't tested with other OS, but suspect that problem is not OS-specific.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 210460 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.