Clicking "Sign In" Causes SSL2 Error 12281

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: gustavo_keener2, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; WinFX RunTime 3.0.50727)
Build Identifier: 1.5.0.3

Detailed Summary: Beginning 15 May 2005, trying to log into any site using SSL2 gives the following error message as a dialog:

"www.foo.com as sent an incorrect or unexpected message. Error Code: -12281"

Searching on the web (including mozilla.org) reveals that this is the most general of SSL errors that can be thrown by a client.  This problem also occurs with Mozilla Firefox on my co-worker's computer.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.google.com [or any website, bugzilla included, that uses SSL2].
2. Click "Sign In" [try to login to bugzilla].
Actual Results:  
Error message dialog pops up:

"www.google.com as sent an incorrect or unexpected message. Error Code: -12281"

Expected Results:  
Firefox should either ignore this error code or perform as it did before 15 May 2005

The first disclaimer to this bug is that, yes, it seems to be a problem with the server sending bad SSL data to Firefox.  

HOWEVER, the reasons I wrote the bug are a) very little was returned regarding this error doing a google search on the web, b) a full uninstall and re-install of Firefox (minus deleting the Windows Registry entries for Firefox) did not resolve the problem, c) starting in safe mode did not solve the problem, d) disabling SSL2 simply makes a different error message appear, e) the problem occurs on any website using SSL2, and f) the problem occurs on more than one independent computer running Firefox.

I have not duplicated the problem from my home, so it is possible that the error is being caused by the way data is being handled here at work.

Needless to say, this bug is being written using filthy IE6 instead of my much preferred Mozilla browser.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5.0.x Branch
(Reporter)

Updated

13 years ago
Severity: trivial → enhancement
(Reporter)

Comment 1

13 years ago
OK.  I'm an idiot.  I forgot to check my connection settings.  

All I needed to do was go to Tools -> Options -> Connection Settings -> Automatic proxy configuration URL:, then add my workplace's configuration script.  Now everything works.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.