Mozilla ActiveX Control not working correctly with a link of "c:\\<something>"

RESOLVED INVALID

Status

Core Graveyard
Embedding: ActiveX Wrapper
--
enhancement
RESOLVED INVALID
12 years ago
6 years ago

People

(Reporter: Carlos Silva, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.3) Gecko/20060516 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.3) Gecko/20060516 Firefox/1.5.0.3

First of all, this is probably the wrong component, but i didn't find anything related to the ActiveX Control.

Anyway, the problem is that i'm trying to run a game (The Matrix Online) via wine that uses Mozilla ActiveX control to display some ingame webpages. One of the first pages still in the login screen is the EULA page, where we have to hit accept. As you may know this is closed source and i only understand this problem because of the error message. The error message is "C is not a registered protocol", so what it tries to do is to load the page from "c:\\<path_to_the_EULA_file>". Looks like the ActiveX Control don't correctly identify this as a valid "protocol" so it doesn't show the file contents. Would it be possible that the Control detects this cases and open the file on the local harddrive?

Reproducible: Always
Firefox -> General for triage
Component: Extension/Theme Manager → General
QA Contact: extension.manager → general
Hot Potato!
-> Core : Embedding : ActiveX
Assignee: nobody → adamlock
Component: General → Embedding: ActiveX Wrapper
Product: Firefox → Core
QA Contact: general → dunn5557
Version: unspecified → Trunk
I would say this isn't Mozilla's fault, and we shouldn't really have to implement something to fix this, but it's a wide-ranging problem with WINE. Perhaps WINE themselves could write something into WINE to prepend "file://" to such URLs?
I recommend WONTFIX.
Severity: normal → enhancement
(Reporter)

Comment 4

12 years ago
If you guys thing that this is wine's fault then i'll move it to wine's bugzie. Anyway, i'm just alerting about this problem. I'll wait for a decision, either WONTFIX/INVALID or ASSIGNED would be nice ;) Just want to know with whom i should talk.
QA Contact: dunn5557 → activex

Comment 5

7 years ago
The ActiveX embedding API was removed in bug 662023 and friends, making this INVALID.

[Filter bugspam on activexinvalid]
Assignee: adamlock → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Assignee)

Updated

6 years ago
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.