"&image" shown as 'ℑ'

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: klassphere, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060517 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060517 Minefield/3.0a1

"&image" (or "(and symbol)image" literally) is substituted by 'ℑ' on FF while it's shown as is on Internet Explorer. I use the en-US trunk build of FF on the Japanese version of Windows XP SP2.

Reproducible: Always
(Reporter)

Comment 1

13 years ago
Created attachment 222332 [details]
testcase

See the source of the HTML file.
(Reporter)

Comment 2

13 years ago
It seems Bugzilla converts & in "&", what I meant is "(and symbol)image" as you see in the testcase HTML.

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
> Gecko/20060517 Minefield/3.0a1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
> Gecko/20060517 Minefield/3.0a1
> 
> "&image" (or "(and symbol)image" literally) is substituted by 'ℑ' on FF
> while it's shown as is on Internet Explorer. I use the en-US trunk build of FF
> on the Japanese version of Windows XP SP2.
> 
> Reproducible: Always
> 

(Reporter)

Comment 3

13 years ago
Created attachment 222335 [details]
testcase pic

This is the pic for how the test case HTML is rendered on FF.
ℑ is an HTML character entity reference for ℑ, so this behaviour is correct. If IE shows it differently, they don't fully support HTML 4
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 5

13 years ago
Created attachment 222476 [details]
revision of testcase, which shows (for me) different behaviour in i.e and ff

I'm sorry if I'm wrong, but consider the following:

There is actually no trailing ; after the entity in the first line of the first test case. ( & image ...)

So it is hard to blame i.e for what may be undefined behaviour.

see --> http://www.w3.org/TR/html4/charset.html#h-5.3

<<Note. In SGML, it is possible to eliminate the final ";" after a character reference in some cases (e.g., at a line break or immediately before a tag). In other circumstances it may not be eliminated (e.g., in the middle of a word). We strongly suggest using the ";" in all cases to avoid problems with user agents that require this character to be present.>>

So what i.e. and firefox do, despite being different, cannot be said to be anything but passable I think. 

The revised testcase shows a different rendering (for me at least) in internet explorer compared to firefox.
I don't have a copy of ISO 8879 handy, but my understanding is that the semicolon can be omitted before any character that would not be valid in the name of an entity. A space is certainly such a character.

Looking more closely at the second test-case, if IE shows &quot as a quote mark, then it is seems to be parsing character references that it recognizes in the same way as Gecko does. It would be interesting to add a character reference that neither browser will recognize to both lines of the test-case (e.g. &foobar and &foobar;)
You need to log in before you can comment on or make changes to this bug.