"ASSERTION: frame was not removed from primary frame map before destruction or was readded to map after being removed" involving submenus

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

({assertion})

Trunk
PowerPC
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Steps to reproduce:
1. Load a page with a subframe, such as data:text/html,<iframe>
2. Right-click the subframe.
3. Hover over "this frame" long enough to make a submenu of the context menu appear.
4. Click below the context menu to dismiss it.

Result:

###!!! ASSERTION: frame was not removed from primary frame map before destruction or was readded to map after being removed: 'Not Reached', file /Users/admin/trunk/mozilla/layout/base/nsFrameManager.cpp, line 698

I first noticed this with the spell-checker context menu, but it's easier to reproduce with the iframe testcase.
Duplicate of this bug: 384483
This is worksforme, using current trunk debug build on windows.
(Reporter)

Comment 3

11 years ago
WFM, Mac trunk debug.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.