Webpage with textarea steal the keyboard focus

RESOLVED INVALID

Status

()

Firefox
Shell Integration
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: bilbon.sacquet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2

Webpage with textarea steal the keyboard focus in certain conditions

Reproducible: Always

Steps to Reproduce:
1. Open a Finder window
2. Choose "Go to the folder" (apple key + shift + g) so a panel opens
3. Go to a webpage with "textarea" (a page of bugzilla report for example)
4. Return to the finder and try to enter a different text in the "Go to the folder" panel.
Actual Results:  
Keyboard don't work in certain part of Finder (some other applications too ?)

Expected Results:  
Don't steal the keyboard

Comment 1

12 years ago
WFM on Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
---
Could you please reproduce this on trunk nightly (3.0a1), latest stable (1.5.0.3), or latest Mozilla1.8.0 nightly (1.5.0.4)?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> WFM on Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8)
> Gecko/20050511 Firefox/1.0.4
> ---
> Could you please reproduce this on trunk nightly (3.0a1), latest stable
> (1.5.0.3), or latest Mozilla1.8.0 nightly (1.5.0.4)?
> 

I've tested that on Firefox 1.5.0.3 and it's no bug.

Comment 3

12 years ago
(In reply to comment #2) 
> I've tested that on Firefox 1.5.0.3 and it's no bug.
> 

Good.  Have you tested on the nightlies (besides 2.0a) yet?
(Reporter)

Comment 4

12 years ago
Argh ... Made some additional tests and it seems to be an Apple Finder bug ...
Probably that the automatic activation of Mozilla spell checker amplify this Apple bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.