If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

using the spacebar to scroll down is confusing when you reach bottom of message

RESOLVED DUPLICATE of bug 32265

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 32265
12 years ago
10 years ago

People

(Reporter: Haakon Steigre, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060308 Thunderbird 1.5.0.2

Using the spacebar to sift through mail and news is great, but when I get to the bottom of the message, the point where I was reading could be anywhere (vertically) in the message window. This makes me look for the line where I can read on, and it takes time. Shrug.

Reproducible: Always

Steps to Reproduce:
1. Load a news group or mail folder with unread messages that are too long to fit on screen
2. Read the content of the message, use spacebar (or pagedown, but make sure the message window has focus) to scroll down, until you get to the end of the message 
3. Get annoyed by having to locate the line where you left off, unless the message happens to be of exactly the right lenght (extremely rare)

Actual Results:  
You lose precious time.

Expected Results:  
It should either a) have some kind of visual eye catcher that shows you where the line is, or b) pad the message with blank lines so that it gets the "right" lenght, or c)..? I'm open to suggestions. preferably, all of the above could be options available in the preferences, with one of them as default. I think I would prefer b).

Comment 1

12 years ago
This is not so much an issue of the mail module, but of the underlying <browser> element (long pages show the very same behaviour eg in Firefox).
[For a workaround see <http://groups.google.com/group/de.comm.software.mozilla.mailnews/msg/c0c146c12a877843?rnum=1>, but it's in German].
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: front-end

Comment 2

10 years ago
Duplicate of bug 299860 -> Core bug 32265.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 32265
You need to log in before you can comment on or make changes to this bug.