When customizing toolbars, search box has grey text and I-beam cursor and is hard to drag

VERIFIED FIXED in Firefox 2

Status

()

Firefox
Search
--
minor
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Gavin, Assigned: mossop)

Tracking

({regression, verified1.8.1})

2.0 Branch
Firefox 2
regression, verified1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Looks like the adding of gray text to the search bar while it's in the palette makes it possible to select that text. The search bar binding constructor should probably not fire if the search bar is in the palette. There was a sort of hacky fix for this at http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/search/content/search.xml&rev=1.56#461 , but I'm not sure that it still works, and there isn't anything that prevents the normal startup in the search bar constructor itself.
This also makes moving the search bar much more difficult. When customizing the toolbars, the "hand" icon is only shown over the engine's favicon and the magnifying glass - otherwise it's a cursor to select text. Combined with the new flex behaviour for the bar length, the majority of the search bar is no use for rearranging. As Gavin points out, this is a regression from v1.5.
Flags: blocking-firefox2?
(Assignee)

Updated

11 years ago
Keywords: regression
This isn't going to block release, but we'd take the polish patch if it's simple.
Flags: blocking-firefox2? → blocking-firefox2-
(Assignee)

Comment 3

11 years ago
I'm a man with a plan.
Assignee: nobody → mossop.bugzilla
(Assignee)

Comment 4

11 years ago
Created attachment 233307 [details] [diff] [review]
patch rev 1

It turns out that the grey text had nothing to do with this and in fact this was a regression from bug 337292 adding extra elements between the textbox and the toolbaritem.

autocomplete.css uses an insanely specific rule to hide the input element of a textbox within a toolbaritem when toolbars are being customized.

This patch simply uses a simpler form of this rule for the specific search bar case.

Also included is code to disable the search bar initialisation when in customization, though that is not actually necessary to resolve this bug so it might be better to leave that out.
Attachment #233307 - Flags: review?(gavin.sharp)
(Assignee)

Comment 5

11 years ago
There is a different patch posted in bug 348947 that appears to be for the same issue as this.
(Assignee)

Comment 6

11 years ago
*** Bug 348947 has been marked as a duplicate of this bug. ***

Comment 7

11 years ago
Changing target milestone to Fx2 and modifying summary since bug 348947 was duped against this.  I think the effects seen on that bug are severe enough to reconsider blocking, so re-requesting.
Flags: blocking-firefox2- → blocking-firefox2?
Summary: Grey text should not appear when the search bar is in the customize toolbar palette → When customizing toolbars, search box has grey text and I-beam cursor and is hard to drag
Target Milestone: --- → Firefox 2
Connor apparently changed his mind on whether or not this blocks final release. OK, I guess. Not blocking beta2, though.
Flags: blocking-firefox2? → blocking-firefox2+
Comment on attachment 233307 [details] [diff] [review]
patch rev 1

>Index: browser/themes/winstripe/browser/browser.css

>+toolbarpaletteitem #searchbar html|*.textbox-input {
>+  visibility: hidden;
>+}

Use |#wrapper-search-container #searchbar html|*.textbox-input| as discussed on IRC, and r=me.
Attachment #233307 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 10

11 years ago
Created attachment 234578 [details] [diff] [review]
patch rev 2

Changed selector as requested. Carrying over review.
Attachment #233307 - Attachment is obsolete: true
Attachment #234578 - Flags: review+

Updated

11 years ago
Whiteboard: [checkin needed]
mozilla/browser/components/search/content/search.xml 	1.85
mozilla/browser/themes/pinstripe/browser/browser.css 	1.30
mozilla/browser/themes/winstripe/browser/browser.css 	1.44
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed] → [needs approval]
Comment on attachment 234578 [details] [diff] [review]
patch rev 2

a=mconnor on behalf of drivers for 1.8 branch checkin
Attachment #234578 - Flags: approval1.8.1+
Whiteboard: [needs approval] → [checkin needed (1.8 branch)]
mozilla/browser/themes/winstripe/browser/browser.css 	1.17.2.46
mozilla/browser/components/search/content/search.xml 	1.37.2.57
mozilla/browser/themes/pinstripe/browser/browser.css 	1.11.4.36
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1 → verified1.8.1
Depends on: 353801
You need to log in before you can comment on or make changes to this bug.