"Open in tabs" on bookmarks removes existing tabs

RESOLVED DUPLICATE of bug 216346

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 216346
12 years ago
12 years ago

People

(Reporter: Stian Soiland, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060410 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060410 Firefox/1.5.0.1

I just added an RSS "Live bookmark" for my del.icio.us thingie, and then selected right-click "Open in tabs".

This removed all my 20 existing tabs and replaced them with **** from the bookmark. I did expect the bookmark tabs to be opened, but not the existing one removed!

Reproduced with firefox-3.0a1.en-US.linux-i686.tar.bz2 and a blank profile.

THIS IS A SERIOUS ISSUE. You don't just close people's tab without asking or warning them! 

You just ruined an hour of work for me as I had been surfing up lots of different websites for a problem at work, and now they all disappeared in a blink. Thank you!

I've not found any very relevant bugs as they seem to talk about some weird property setting which I have never touched. As this was verified even with a blank profile, there is some serious misbehaviour here.

Reproducible: Always

Steps to Reproduce:
1. Open new tabs surfing different things
2. Right click and select "Open all tabs" for instance from Bookmarks->Firefox links

Actual Results:  
All your original tabs disappears and is replaced by the bookmarks. Your hands will smash into the desk while you are crying and some blood will appear.


Expected Results:  
Keep the existing tabs, and add the bookmark tabs to the end.

Comment 1

12 years ago
Please take a deep breath and accept that this issue won't be fixed. As a work-around, either set the hidden pref browser.tabs.loadFolderAndReplace to false (in about:config) or get yourself a tabbed browsing extension.

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
Are you crazy? You cannot have this a default behaviour.  Nobody who clicks something like "Open in tabs" will expect all their current tabs to disappear. 
They expect the bookmarks to "open in tabs", NEW tabs. 

These rare people who actually like this behaviour can go and set the appropriate preference. You can't have a destructive behaviour as a default without warning the user or anything.

What is the next thing, clicking "Print" will delete all your bookmarks?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

12 years ago
Apparently they can... anyway, you might be glad to hear that this issue might be alleviated for Firefox 2 through the fixes for bug 175124 (don't close the tabs but add to the history of the existing ones and just leave surplus tabs alone) and bug 254021 (allow to reopen accidentally closed tabs). Until then be assured that the two options I mentioned are your only ones.
Whether or not you like the resolution of bug 216346, this bug is a duplicate of it. Please do not reopen it.

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.