Searchbar accessible name is not descriptive enough

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
13 years ago
12 years ago

People

(Reporter: pilgrim, Assigned: pilgrim)

Tracking

({access, regression})

2.0 Branch
Firefox 2
x86
Windows XP
access, regression
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

13 years ago
Steps to reproduce:

1. Run Inspect32
2. Tab to searchbar
3. Accessible name is always "Search"

Hovering the cursor over the search button shows "Search Google" or "Search Yahoo" or whatever.  I expected the textbox's accessible name to include the name of the search engine as well.

Comment 1

13 years ago
Absolutely, this is a regression. I'd prefer not to call regressions minor.

Mark, can you find out who regressed this and get them to fix it?
Severity: minor → normal
Flags: blocking-firefox2?
Keywords: regression
Note that there are no longer tool tips on the search bar on the branch, they were removed in bug 311653.

Comment 3

13 years ago
(In reply to comment #2)
> Note that there are no longer tool tips on the search bar on the branch, they
> were removed in bug 311653.

The accessible name had keyed off of those. The accessible name should be what the tooltip used to be.
This never really worked right, since the tooltip was always broken (i.e. it could be something completely unrelated).

Not going to block on this, since it's at least usable, but would take a safe patch.
Flags: blocking-firefox2? → blocking-firefox2-

Updated

13 years ago
Assignee: nobody → pilgrim

Comment 5

13 years ago
This works on trunk, and it's not important enough to worry about in the short time frame for Firefox 2.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 6

12 years ago
*** Bug 358893 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.