very very long URL causes overlaid text in URL bar

RESOLVED DUPLICATE of bug 295769

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 295769
12 years ago
12 years ago

People

(Reporter: Mark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060504 Fedora/1.5.0.3-1.1.fc5 Firefox/1.5.0.3 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060504 Fedora/1.5.0.3-1.1.fc5 Firefox/1.5.0.3 pango-text

When submitting long form via GET, form data in URL causes overlaid text. I have a cropped screenshot which shows this.

Reproducible: Always

Steps to Reproduce:
1. Go to http://jigsaw.w3.org/css-validator/validator-text
2. Enter lots of CSSv2 into edit box.
3. Click "Submit this CSS for validation" button

Actual Results:  
Firefox URL bar shows overlaid text. It makes a Latin-1 char set look like Urdu or something.

Expected Results:  
A human-readable URL bar.

Clicking in the URL bar and then moving the caret seems to give some relief.

I will attach the screenshot and the submitted CSS for your attempts to duplicate this bug.
(Reporter)

Comment 1

12 years ago
Created attachment 222582 [details]
URL bar has overlaid text
(Reporter)

Comment 2

12 years ago
Created attachment 222583 [details]
CSS submitted in form

Enter this attachment's contents into the "Text" edit box, then click "Submit this CSS for validation". Hopefully, you will see overlaid text similar to the image I have attached.
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Do get the same result while using the default theme? Could you also try an official binary?

Updated

12 years ago
Blocks: 302294

*** This bug has been marked as a duplicate of 295769 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
No longer blocks: 302294
You need to log in before you can comment on or make changes to this bug.