Textarea doesn't show complete predefined content and POSTS truncated value

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: a_brachhold, Unassigned)

Tracking

({dataloss})

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/05)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

I'm using the Blogging software WordPress. Sometimes when I edit a post, Firefox doesn't show the complete content of the predefined value in the textarea. If I don't see that and submit the form, the "hidden" content is lost.

This happens from time to time on larger posts. It's not a fault of WordPress because the full post is set as the textarea value (I've looked at the source when it happened the last time).

The position where firefox stops to display the content seems to be random. In the attached data, it's line 117, character 80, which is not a special character but in a normal word.

Reproducible: Sometimes

Steps to Reproduce:
1. Install blogging software wordpress (wordpress.org) or create a page with a textarea
2. Create a post or set the textarea content to the attached content.txt
3. Reload the page several times until Firefox truncates the content of the textarea.

Actual Results:  
Firefox stopped displaying the textarea content at line 117, character 80 (attached data)

Expected Results:  
Firefox should display all content

Set to critial because I lose the half of my post data when I submit the trunctated content. I thinks it's happening since I've upgraded to Firefox 1.5.0.3.
(Reporter)

Comment 1

13 years ago
(Reporter)

Updated

13 years ago
Keywords: dataloss
Version: unspecified → 1.5.0.x Branch

Comment 2

13 years ago
I've noticed this happening too with WordPress, usually when there is a very large amount of stuff in the textarea -- either a long post, or a PHP file I'm editing.

There is a chance that this is a WordPress issue, it could possibly be the javascript in the admin area. I must say that I don't recall anything similar happening with a different web application.

Comment 3

13 years ago
I have noticed this bug also. I am using Firefox 1.5.0.4 on WinXP SP2.

Here are my steps to reproduce this problem:
1) open firefox and type http://cnn.com into the address bar.
2) hit ctrl-t to get a new tab
3) type http://support.cogix.com:81/trunc.html into the address bar on the second tab. after the page loads, scroll to the bottom of the textarea and note that the last line reads "THE END"
4) hit ctrl-tab to cycle to the cnn.com tab.
5) hit ctrl-tab again to cycle back to the page loaded in step #3 above. Scroll to the bottom of the textarea and note that the displayed text is truncated prior to "THE END" that was observed in step #3.
(Reporter)

Comment 4

13 years ago
I can confirm this beaviour with the steps noted in comment #3. This bug is NOT WordPress related, it's a Firefox fault.

Comment 5

13 years ago
(In reply to comment #4)
> I can confirm this beaviour with the steps noted in comment #3. This bug is NOT
> WordPress related, it's a Firefox fault.
> 

Yes, I tried the example with CNN as well, and the same thing happened. It seems to be switching between tabs that triggers this.

Comment 7

13 years ago
I have narrowed this bug down to changing tabs with a large amount of text in a textarea element - see new attachment called "Simple replication"

The textarea on the above page will truncate it's content (as most easily witnessed by the length of the horizontal bar lengthening) when switching to another tab and back.
I am using Firefox 1.5.0.4 on WinXP SP2.

Comment 8

13 years ago
Verry annonying. Happens on tab switch for any textarea that contains more then 600 lines... on..

Gecko/20060728 Firefox/1.5.0.6

Comment 9

13 years ago
I can confirm this. This is a really critical bug. We have a newsletter tool and our newsletters were sent truncated to our customers. At the moment we can't use firefox for this.

Comment 10

13 years ago
I can reproduce this problem only on one machine (the marketing guy who sends the newsletter) in our company. So, maybe this bug is caused by some buggy addon?
I asked him and one of our customers who had the same problem on firefox for a list of their addons. Maybe this helps a little to localize the bug:

1)
=====
Google Toolbar for Firefox 2.1.20060807W
RankQuest SEO Toolbar 1.0
Google Pagerank Status 0.9.6
SEOpen 0.7

2)
=====
DOM Inspector 1.8.0.6
Google Toolbar for Firefox 2.1.20060807W
Html Validator 0.7.9
View formatted source 0.9.4.6
View Rendered Source Chart 1.5.02
Web Developer 1.0.2
IE Tab 1.0.8

If you have the same problem, do you have the same addons? Especially this addon "Google Toolbar for Firefox 2.1.20060807W"? Does the error still appear if you turn it off?
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/05

Comment 12

12 years ago
In Firefox 2 it seems to work again... We don't have the problem anymore.
-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.