Frameset splitter movement is broken/sluggish and does not stay where you drop it

VERIFIED DUPLICATE of bug 12002

Status

()

Core
Layout: HTML Frames
P3
major
VERIFIED DUPLICATE of bug 12002
18 years ago
18 years ago

People

(Reporter: billw, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; NT4.0; en-US) Mozilla/m13
BuildID:    2000022820

When a window split is moved on a page with frames, the splitter moves
to a position OTHER than where it was specified to move to (beyond, ie
larger than), and the extra section scrolls very strangely.  The scroll bars
disappear, so one must use the mouse to scroll up and down.


Reproducible: Always
Steps to Reproduce:
1.Create a javadoc set of documentation	
2.Open index.html
3.Move splitter


Actual Results:  Splitter moves to different position.
Right-hand window behaves VERY strangely.
Scroll bar disappears.	


Expected Results:  Splitter should move to dropped position.
Splitter should move smoothly.
Right-hand window should be re-sized properly.
Scroll bar should be redrawn.	


I would provide an example, but mozilla crashes on www.javasoft.com every time I
try to go there.
(Assignee)

Comment 1

18 years ago
I think I've seen this one before, I'll look for the duplicate...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Table splitter movement is broken/sluggish and does not stay where you drop it → Frameset splitter movement is broken/sluggish and does not stay where you drop it
(Assignee)

Comment 2

18 years ago
Found it, bug 12002.  I recently fixed the problem where nested framesets don't
calculate their resizing offsets correctly.  This should fix any problems with
"not staying where you release it".

*** This bug has been marked as a duplicate of 12002 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Marking verified dup of 12002.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.