Debugger won't start more than once.

RESOLVED WONTFIX

Status

Other Applications
Venkman JS Debugger
--
major
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: Danielle L, Assigned: Robert Ginda)

Tracking

1.8 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Logged on. Started debugger. Noticed was on the wrong page. Closed debugger. Opened right page. Attempted to start debugger. Nothing. Closed all firefox windows. Opened new window. Opened right page again. Attempted to start debugger twice more. Nothing. Nothing.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox.
2. Start debugger.
3. Close debugger.
4. Start debugger.

Actual Results:  
Debugger did not start the second time.

Expected Results:  
Debugger should have started.

Comment 1

12 years ago
This is a bug in Firefox. I can't be arsed trying to work out WHAT it is, but it works fine in Firefox's latest code (code-named Minefield). For Firefox 1.5 and 2.0 you must quit Firefox entirely (File > Quit) to reopen Venkman.

Comment 2

12 years ago
*** Bug 339974 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
*** Bug 344595 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
Happens on my computer as well under:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

I just upgraded to latest version, as per comment, and the problem still happens. NOTAFIX.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

File->Quit does not solve the problem for me; the only way to bring the JS debugger up again is to reboot the whole computer. NOTAFIX.

Comment 5

12 years ago
Please feel more than free to search through all the millions of code changes between Firefox 2.0/1.5 and trunk development and find out what fixed the problem, so that it can be applied to 2.0. Until someone does that, there is unlikely to be any change in behaviour until Firefox 3.0 comes out. If quitting Firefox from File > Quit does not work, that is a seperate Firefox bug (it is probably not quitting completely).
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → 1.8 Branch

Comment 6

12 years ago
*** Bug 353631 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
Confirming to make finding easier, but this bug is really WONTFIX - it is a 1.8 branch bug that has been long-fixed on trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

12 years ago
So for posterity's sake, note bug 310319 comment 10
Depends on: 310319

Comment 9

12 years ago
... mentions that this bug was caused by that bug. Sorry for the spam.

Comment 10

12 years ago
*** Bug 322746 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Duplicate of this bug: 358313

Comment 12

12 years ago
Here is solution how to start Venkman second time:

After you close Venkman, and not able to open it again, you have to terminate FireFox using task manager. After you do that, start FireFox again, and it will ask you if you want to start a new session, or no. Click on "start new session", after wich Venkman will start properly. In order to avoid that, use File->Quit menu on venkman.

And if someone wants to resolve this issue, I recommend looking into FireFox session information, aperently when you close Venkman using "X" button, in some config file there is still a flag than venkman running. Maybe it is not the case, however when I click on "Start new session" button after terminating FireFox through Task Manager - everything is working properly.

Comment 13

12 years ago
We already know exactly why it doesn't work, it's bug 310319. The fix for that bug is not being allowed onto the 1.8 branch, so you *will* have to wait for Firefox 3 for this to work again - there is nothing (sane) we can do.
per comment 13, RESO WONTFIX
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.