Print preview displays <a> tags between <noscript> tags as text instead of interpreting them

RESOLVED DUPLICATE of bug 338592

Status

()

--
major
RESOLVED DUPLICATE of bug 338592
13 years ago
13 years ago

People

(Reporter: jondmorrow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

When a page containing JavaScript and alternate <noscript> HTML is viewed in Firefox with the "Print Preview" command, two irregularities will appear in the on-screen and printed versions:

   1. The background will be grey instead of white.
   2. Any HTML tags between the <noscript> tags will be printed verbatim as text instead of being interpreted as HTML.  For example, <noscript><a href="http://www.google.com/">Search Google</a></noscript> will be displayed and printed literally as "<a href="http://www.google.com/">Search Google</a>".

When the page is printed in Firefox using the "Print" command without previewing it first, only irregularity #1 will appear, not #2.

When the JavaScript snippet is removed from the source, the page prints properly in all cases.

I've posted a self-documented example at http://tofu.f2o.org/ff/ff-print.html


Reproducible: Always

Steps to Reproduce:
1.  Visit http://tofu.f2o.org/ff/ff-print.html
2.  File > Print Preview.  Notice the HTML code printed next to the "Close" button, at the end of the page.
3.  Print.  Notice the HTML code prints as literal text.  Also notice the grey background.
4.  Now try File > Print (without previewing).  Notice that the HTML code doesn't print, but the background is still (wrongly) grey.
5.  Now follow the link on the page to the version without any JavaScript.  Notice that the page prints properly, with a white background.

Actual Results:  
The HTML code prints as literal test.

Expected Results:  
The HTML code shouldn't have printed.  The hyperlink should be displayed as a hyperlink.

Happens even in FF safe mode.

*** This bug has been marked as a duplicate of 338592 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.