Canvas is getting slower

RESOLVED INVALID

Status

()

Core
Canvas: 2D
P3
normal
RESOLVED INVALID
12 years ago
7 years ago

People

(Reporter: gandalf, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
We did some tests between Fx 1.5 and Fx 2.0a2 and it seems that this games works slower in Fx 2.0a2 and it was working very slow in Gecko 1.9.

Steps to reproduce:

1) Open the game in Fx 1.5
2) Open the game in Fx 2.0
3) Open the game in Fx 3.0
4) Compare the speed. The best moment is to compare the moment when the bomb blows  and it slows down the movement of the player.
(Reporter)

Comment 1

12 years ago
http://www.zwitserloot.com/2006/05/20/back-to-the-bomberman/

quote:
Current standings, measured when 1 bomberman is running, a bomb is pulsing, and one explosion is going off, all measured on my iBook G4 1.333 Ghz (50 is max):

safari 2.0.3: 44
firefox 1.5.0.3: 15
firefox 1.6a1 (Deer Park Alpha 2): 18
opera 9 preview 1: 36
(Commented on the guy's blog, too)

The Mac builds are significantly slower than windows; this probably won't be fixed on the trunk for a while (there's a bunch of prereq work that needs to happen).  Windows builds are much faster -- on my laptop, with the CPU locked down to 800MHz, I never see below 35fps or so using a debug build of Bon Echo (Fx2 alpha2).

Anything calling itself Deer Park Alpha 2 is also quite old, so I asked him to rerun his timing tests on a new Bon Echo/Minefield release.

Also on my machine, a Minefield build from 0512 never goes below 50fps (and was even showing 50-60 a good deal of the time?).
(Reporter)

Comment 3

12 years ago
Vlad: Can you compare your speed diff between 1.5 and 1.8branch and trunk on Windows?

On Linux I see difference, and on mac we saw difference too.

(any reason that might cause the drop between 1.8.0 and 1.8 branch?)
(Reporter)

Comment 4

11 years ago
I can still reproduce major slowdown for this bug with recent trunk (2007110511) on Linux.
(Reporter)

Comment 5

11 years ago
cannot reproduce this on Windows. On Windows trunk is faster than Fx2.

Marking as linux only
OS: All → Linux
Hardware: All → PC
Version: 1.8 Branch → Trunk
We now create a native platform surface for canvas; maybe on linux we should always use the software-only surface, since it's known to be significantly faster than going through X and Render in many cases...
Under the presumption that Linux perf is still an issue. If not, someone should resolve WFM.
Priority: -- → P3
Linux canvas performance is pretty dependent on which drivers are being used. If this is still an issue please create a new bug with more information about drivers etc.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.