When downloading a .torrent file, Firefox will not pass the fille correctly to the Azureus application.

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: douglas_jay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

When firefox is set to use the helper application Azureus to handle .torrent files, after the file has finished downloading it successfully opens the Azureus program, but does not correctly relay the file.  In essence, the downloaded file is not passed correctly to azureus and therefore one must then manually open the file.  When using other browsers this is not a problem and works correctly, the problem only occurs when using Firefox.

Reproducible: Always

Steps to Reproduce:
1.Download a .torrent file
2.Tell firefox to open the file with azureus
Actual Results:  
Once downloaded Azureus will open, but the file is not passed correctly and the downloaded file will not open.


Expected Results:  
The file should be correctly opened by Azureus.

This was not a problem with pre 1.5 versions of Firefox, and possibly with early 1.5 versions, but I can not remember.

Comment 1

13 years ago
I have this problem too, but I assumed it was a bug in Azureus.  Hmm.

Comment 2

13 years ago
If I drag a .torrent file to Azureus's dock icon (while Azureus is open), Azureus takes focus but does not do anything with the file.  So I think this is a bug in Azureus.  I'm surprised that you say it works with other browsers, though.
Reporter

Comment 3

13 years ago
I have always noticed this problem, but always thought it was Azureus for Mac's issue, until I accidentally used Safari to download a torrent and it worked correctly.  I did a google search and found numerous other people experiencing the problem and non sounded like they expected a fix, but all blamed firefox as the culprit.

I love firefox, but I only use a browser for 2 things and ebay works great...so....

Comment 4

13 years ago
Firefox used to process .torrent files the way I wanted it to, but now, when I click on a .torrent file in a webpage, it tries to open the .torrent file with Quicktime!!! WTF is up with that? I tried the View & edit Actions button to fix it, but I couldn't find an entry for .torrent files in the list. The only file extension in the entire list that starts with a T is TIF files. Strangely enough, when I right click and save the torrent file to my HD, then after download is complete click Open in the download manager, my BitTorrent client opens correctly. 

Comment 5

13 years ago
Fixed in Azureus 2.5.0.0, released today.

http://azureus.sourceforge.net/changelog.php?version=2.5.0.0
"UI | OSX: Open .torrent files into Azureus via Finder/Desktop/etc"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.