A4tech mouse with 2 wheels - horizontal scrolling doesn't work

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: crambe, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

I bought an A4Tech WOP-49 two wheels mouse (in order to make browsing less tiring on an 800x600 monitor),but it can't scroll the pages horizontally in Firefox, instead it wheels vertically, just like it worked before installing the mouse's software. The wheel does work with Internet Explorer and MS Office. Other buttons in Firefox (ie. vertical wheel/middle button while browsing tabs) work after setting.
 ((I'd feel sorry, if i had to use IE again  ;-/))

Reproducible: Always

Actual Results:  
Adjusted the mouse's software, 
restarted Firefox, 
problem remained

Expected Results:  
scroll horizontally :)
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
(Reporter)

Comment 2

11 years ago
Yes Steve, nothing has changed about scrolling. I upgrade Firefox automatically for every new version and build. BTW the scroll wheel doesn't work in Opera either, but there it's not a big problem, because of the "Fit to width" function, which is even better than scrolling... (Could such function be put on feature wish-list of FF 3?)
Version: 1.5.0.x Branch → 2.0 Branch

Updated

11 years ago
Whiteboard: CLOSEME 06/27

Comment 3

10 years ago
No horizontal scrolling here in Fx 2 or now Fx 3.0, under Windows Vista with an Alps laptop touchpad. As above, all other Windows apps I know of capable of horizonal-scrolling something respond to the feature, so I suspect there is some generic Windows functionality that is being ignored/missed by Firefox. Same issue in Thunderbird too.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.