Indefinite Hourglass Hang After First POP3 Mail Download With New Profile

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: elevatorsout, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2
Build Identifier: Thunderbird version 2 alpha 1 (20060521)

When using Thunderbird 2a1 with a new profile, after setting up new POP3 account and downloading for first time I get a continuous and indefinite hourglass.  The hourglass does not go away - as if it is looping some process continuously.

Reproducible: Always

Steps to Reproduce:
1. Make sure you are opening a fresh profile in Thunderbird 2a1
2. Use the import wizard.
3. On the first screen select "don't important anything" and click next.
4. Select "e-mail account" on the next screen. click next.
5. Type in your name and e-mail address as prompted on the Identity screen. click next.
6. On the "Server Information" screen be sure to select POP and enter your server information.  Make sure "Global Inbox" is selected. click next.
7. Type in your username on the next screen. Click next. 
8. Click next at the account name screen.
9. Be sure to UNCLICK the "download messages now" box.  Click Finish.

10. Now go straight to account settings in the tools menu.
11. Under Server Settings click "leave messages on server"
11a. Also click "until I delete or move them from inbox"
11b. click OK.
12. Click the GET MAIL button.
13. enter your password and click "use password manager to remember this password."  Click OK.  And Click OK on the Alert.
14. Click the GET MAIL button again and Wait for ALL your mail messages to download.
15. Expand Local Folders by click on the plus next to "local folders"
16. Select your Inbox by single clicking on it
15. 
Actual Results:  
When your mouse is over the mail messages window (where you see what new messages your have) an hourglass appears and never goes away.  In the preview pane you see the "welcome to thunderbird" message.  

If you click on a message you will see the message in the preview pane, but the header information will not appear.

If you next select "Local Folders" and then try to click back to your inbox Thunderbird only show the hourglass and will not go back into your inbox. Further the readout in the bottom left says "unread -1 total -1"

On the other hand if you select your unsent messages folder and move back to your inbox your messages will appear again, but with the hourglass still moving.

Expected Results:  
No continuous and indefinite hourglass.  The newest e-mail should be highligted and showing in the preview pane.  Moving between local folders and inbox (after first being in inbox) should allow you to see your messages.  Message headers should appear when clicking on a message.  

Oh and did I say you shouldn't get an hourglass that doesn't want to go away???
(Reporter)

Comment 1

13 years ago
After further review I found that it does not matter if you uncheck "download messages" now.  Nor does it matter if you go straight to account settings.  Clicking on the Inbox always brings up an hourglass on the first trip into it after running the wizard.  However, the only way I have found to get the -1, -1 readout is by following the steps I meticulously outlined above.  

Also note that if you leave thunderbird and come back the problem no longer occurs.  It just happens the first time. 
QA Contact: front-end

Comment 2

11 years ago
Do you still see this problem in current versions of trunk or 2.0 build?

2.0:http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/2.0.0.5/

trunk:http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/

No response since last comment for almost 1 year, resolving incomplete.

Please comment if the issue still occurs in the latest 2.0.0.x / trunk nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> No response since last comment for almost 1 year, resolving incomplete.
> 
> Please comment if the issue still occurs in the latest 2.0.0.x / trunk
> nightlies.
> 

I tried it today with the official 2.0.0.14 release of Thunderbird.  I uninstalled all versions of Thunderbird from my computer and removed my profile folder.  

I did not have the problem, however, I only had one e-mail to download, whereas previously I had multiple e-mails.  Therefore, I'm not sure it was a fair test.  I'm going to try again with a different e-mail account that should have plenty to download.
(Reporter)

Comment 5

10 years ago
I tried again with clean profile, but this time with an e-mail account that had plenty of e-mails to download (over 8000) and it appears that this bug has been resolved with the 2.0.0.14 release.
Resolution: INCOMPLETE → FIXED
->WORKSFORME ("FIXED" is reserved for know code fixes)
https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.