No history search results.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: kennypg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Upon tying a single letter in the search box, the entire history vanishes. I had the same problem in the previous version of Firefox. I think this bug may have already been reported as: 337384  but the description is sketchy, so I'm not sure.

Reproducible: Always

Steps to Reproduce:
1.open history sidebar
2.start typing in search box
3.

Actual Results:  
history sidebar becomes blank.

Expected Results:  
provided results that matched my search term

Comment 1

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> 
> Upon tying a single letter in the search box, the entire history vanishes. I
> had the same problem in the previous version of Firefox. I think this bug may
> have already been reported as: 337384  but the description is sketchy, so I'm
> not sure.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.open history sidebar
> 2.start typing in search box
> 3.
> 
> Actual Results:  
> history sidebar becomes blank.
> 
> Expected Results:  
> provided results that matched my search term
> 

Yes, I'm having the same issue and reporting it as bug 337384, which admittedly was sketchy to say the least :)

I've tried it with Firefox 1.5.0.4 as well but the problem still exists.

I've looked at 'Places' and this bug is a different issue.
I do this using today's bon echo build on the Intel Mac - Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1a3) Gecko/20060621 BonEcho/2.0a3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
As the reporter notes, this behavior is present in the 1.5.0.x branch. If I type a search term that matches a term in my history, it does find it.

(In reply to comment #2)
> I do this using today's bon echo build on the Intel Mac - Mozilla/5.0
> (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1a3) Gecko/20060621 BonEcho/2.0a3.
> 

(Reporter)

Comment 4

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> 
> Upon tying a single letter in the search box, the entire history vanishes. I
> had the same problem in the previous version of Firefox. I think this bug may
> have already been reported as: 337384  but the description is sketchy, so I'm
> not sure.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.open history sidebar
> 2.start typing in search box
> 3.
> 
> Actual Results:  
> history sidebar becomes blank.
> 
> Expected Results:  
> provided results that matched my search term
> 

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> 
> Upon tying a single letter in the search box, the entire history vanishes. I
> had the same problem in the previous version of Firefox. I think this bug may
> have already been reported as: 337384  but the description is sketchy, so I'm
> not sure.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.open history sidebar
> 2.start typing in search box
> 3.
> 
> Actual Results:  
> history sidebar becomes blank.
> 
> Expected Results:  
> provided results that matched my search term
> 


Uh, is anyone working to fix this?

Comment 5

12 years ago
(In reply to comment #4)
> Uh, is anyone working to fix this?
> 

This bug still exists in all subsequent updates since 1.5.0.3 including 2.0 and 2.0.1

I tried going through the source code of version 1.5.0.3 and the problem seems to be with the javascript.

I'll have a closer look but I thought I'd share this lead. My expertise in javascript are limited so I'm afriad I can't provide any further relevent details at this stage.

Comment 6

12 years ago
This MAJOR bug still exists in 2.0.0.3. This is such an obvious bug it bring the perceived quality of Firefox down for a lot of people.
Does anybody have this working correctly?  I just tried on a new profile on a new user and it doesn't work there.

Tariq - what lead you down the javascript path?  I don't see any messages in the error console... just curious.

Updated

11 years ago
Duplicate of this bug: 337384

Comment 9

11 years ago
I think this might be an Intel-only problem.  It looks like from this bug and
337384 (a dupe of this bug) that all the people posting their useragents have Intel macs, and the only person who said "WFM" is on PPC.

I never had this problem until recently when I switched from a PPC to Intel.

Comment 10

11 years ago
Confirmed in 2.0.0.12, OS-X.  If Intel-related, it's only on Macs.  Wintels are OK.

Comment 11

10 years ago
I also see this on Solaris SPARC (Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.13) Gecko/20080407 Firefox/2.0.0.13).

Comment 12

10 years ago
History search seems to work in 2.0.0.14, OS-X 10.5.2.

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks

Comment 13

10 years ago
Also working in Firefox 3.0.1, OS-X 10.5.4
Can anyone reproduce this in 3.1 b3 or trunk?

Comment 15

10 years ago
Can't reproduce it in 3.1b3 (OS-X 10.5.6)
I'm going to mark this as WFM, but if anyone see this again in 3.1 or current 3.2 trunk, he's free to reopen the bug report.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.