{inc}Border, Float:Left, and Display:block causes select box to grow infinitely

RESOLVED FIXED

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: Andy, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

See attached link.

When resizing the window in either direction, the select box grows infinitely  (appears as though margin-right is reapplied to the select box). 

Reproducible: Always

Steps to Reproduce:
1. Resize the window to make the screen larger, notice size change.
2. Resize the window to make the screen smaller, notice size change.

Actual Results:  
The select box increases in width, no matter the direction of resizing the window.

Expected Results:  
The select box should grow when the window is made larger and shrink when window is made smaller.
(Reporter)

Comment 1

12 years ago
Created attachment 222893 [details]
Select box grows infinitely
(Reporter)

Updated

12 years ago

Comment 2

12 years ago
well i don't see any bug here.

it doesnt grow infinitly, it grows at most as 100% of the page.

it's just tag soup with an nested element that has 100% width and parent thats forced into an ugly in-between state of display block/inline because of the float left in the outer div.

remove the useless float:left in the outer div or the useless display:block from the label
(Reporter)

Comment 3

12 years ago
I think you missed the point - just because you see an easier way to mark up (AN EXAMPLE!) doesn't mean a defect doesn't exist. This example has been stripped down to illustrate the <i>defect</i> in question. 

Yes, there are easier ways to mock this up - but calling "display:block" useless just doesn't make any sense. What if I want to set a width on a label so that they all have the same width? (eg: to markup a form without using tables)

I say, relax a little bit, get over yourself and give this one another read.

Thanks,
Andy

(In reply to comment #2)
> well i don't see any bug here.
> 
> it doesnt grow infinitly, it grows at most as 100% of the page.
> 
> it's just tag soup with an nested element that has 100% width and parent thats
> forced into an ugly in-between state of display block/inline because of the
> float left in the outer div.
> 
> remove the useless float:left in the outer div or the useless display:block
> from the label
> 

(Reporter)

Comment 4

12 years ago
You are correct that it doesn't grow 'infinitly'; I didn't use the correct term here, so that I could be more direct.

More clearly: the select box seems to contiuosly re-apply the right-margin it has set in its style attribute. 

BTW, this affect occurs on FF for Mac, Win, and RedHat Linux.

Thanks,
Andy

(In reply to comment #2)
> well i don't see any bug here.
> 
> it doesnt grow infinitly, it grows at most as 100% of the page.
> 
> it's just tag soup with an nested element that has 100% width and parent thats
> forced into an ugly in-between state of display block/inline because of the
> float left in the outer div.
> 
> remove the useless float:left in the outer div or the useless display:block
> from the label
> 

Comment 5

12 years ago
Confirmed on Mac, trunk.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060521 Minefield/3.0a1
Status: UNCONFIRMED → NEW
Component: Form Manager → Layout: Form Controls
Ever confirmed: true
Keywords: testcase
OS: Linux → All
Product: Firefox → Core
QA Contact: form.manager → layout.form-controls
Hardware: PC → All
Version: unspecified → Trunk
I do see this with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120404 Minefield/3.0a1 [cairo]
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.1) Gecko/20061206 BonEcho/2.0.0.1 ID:2006120603

I don't see this with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120607 Minefield/3.0a1 [reflow]

adding {inc} to summary
Summary: Border, Float:Left, and Display:block causes select box to grow infinitely → {inc}Border, Float:Left, and Display:block causes select box to grow infinitely
Weirdness observed with:
-  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a
(testcase 1px blue border grows wider as the browser window is resized)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1
(testcase 1px blue border remains static)

-->RESOLVED FIXED 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Depends on: 300030
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.