Add me to cc list feature is confusing

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Creating/Changing Bugs
P4
trivial
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: timeless, Assigned: Joost de Valk)

Tracking

2.20
Bugzilla 3.0
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

709 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
So, i've been using bugzilla now for 3 weeks. hrm, there's something very wrong with that statement, but please bear with me :). Note that normally I file bugs against bugzilla 2.20.1, I'm going to have to be careful to try to remember to set the version number appropriately based on what I'm using.

Anyway, it turns out that whne I look at users, I see:

Thing Confusing <confusing.thing@do.main>

I've started typing "Thi" in the multiselect add cc listbox in order to enable me to CC someone named "Thing Confusing", this almost makes sense. Except for one minor detail.

Under additional comments there's this:

[ ] Add confusing.thing@do.main to CC list 

I have no idea what confusing.thing is, even though it happens to be me, because I now think of myself as "Thing Confusing". While it might make perfect sense to offer "add email address to CC list", it's not what I come to expect when the CC list items list real name first and not email addresses.

Steps to reproduce:
1. setup user email accounts using longfirst.last@do.main
2. mess up your users tiny little minds by sticking last name first into the real name field
3. have them use bugzilla to CC a number of other people to bugs for 2 weeks.
4. let your user decide to visit amsterdam (this isn't strictly required to reproduce, but it's quite fun, I highly recommend it, but bring hard currency, they don't take American Express, or Visa, or MasterCard, although they sometimes take MaestroCard [go figure])
5. send your user a bugmail showing a cc of your user, as a reminder to your user that your user should perhaps CC self to bugs while making changes/reassignments.
6. as user, try to cc yourself using the CC list, since after all, that's the logical thing to do.
7. as user, read the bug page and totally fail to comprehend what this Add confusing.thing@do.main to CC list is.

Expected results:
Add option at the very least needs to have Real Name included in the same order as it would appear in CC List.

It should probably also include a hint (which could be disabled by the user upon recognizing what the BLEEP the feature is for, that explains that this is a way to _add yourself_ to the CC list).

Comment 1

12 years ago
IMO instead of displaying the full name if it is available, we should just say 'Me'.
OS: Windows XP → All
Hardware: PC → All

Comment 2

12 years ago
If you can't remember your own Bugzilla login name, something is seriously wrong, particularly since it's usually your email address.

We could just add "(myself)" after the login name.

Don't just say "Me." That can be confusing for people with multiple accounts.
Severity: normal → trivial
Priority: -- → P5
(Assignee)

Comment 3

12 years ago
Created attachment 227292 [details] [diff] [review]
Patch
Assignee: create-and-change → bugzilla
Status: NEW → ASSIGNED
Attachment #227292 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #227292 - Flags: review? → review?(myk)
(Assignee)

Comment 4

12 years ago
Created attachment 227294 [details] [diff] [review]
Updated patch
Attachment #227292 - Attachment is obsolete: true
Attachment #227294 - Flags: review?(mkanat)
Attachment #227292 - Flags: review?(myk)

Comment 5

12 years ago
Comment on attachment 227294 [details] [diff] [review]
Updated patch

Yeah, this looks good.
Attachment #227294 - Flags: review?(mkanat) → review+

Updated

12 years ago
Flags: approval?
Priority: P5 → P4
Target Milestone: --- → Bugzilla 3.0
Flags: approval? → approval+
(Reporter)

Comment 6

12 years ago
mkanat: i have a few instances of me that i will always recognize, timeless is one of them. i explained clearly in steps to reproduce why this artificial instance is *not* something i would recognize, especially after taking a vacation for a weekend.

Comment 7

12 years ago
Checking in template/en/default/bug/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/edit.html.tmpl,v  <--  edit.html.tmpl
new revision: 1.83; previous revision: 1.82
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.