with browser.search.openintab set to "true", when the current tab is about:blank (new tab) don't open a new tab when searching, and also when opening new URLs from external programs

RESOLVED DUPLICATE of bug 302352

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 302352
13 years ago
13 years ago

People

(Reporter: piratepenguin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060522 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060522 Minefield/3.0a1

When searching and when clicking links in other programs (e.g. GAIM), don't open a new tab when the current page is about:blank

Reproducible: Always

Steps to Reproduce:
1. with browser.search.openintab set to "true", open a new tab
2. search for "blah" in e.g. Google
Actual Results:  
a new tab opens with the search results

Expected Results:  
use the current page if it is @ about:blank
This behaviour makes sense to me, for how should the program know for what purpose you opened a blank tab?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> This behaviour makes sense to me, for how should the program know for what
> purpose you opened a blank tab?
> 

It wouldn't /know/, but I, for one, have no good use for staying at a blank tab :)

I suppose there are times when one wouldn't want this functionality, but for me at least, I can't imagine the bad out-numbering the good.

Maybe I just shouldn't have turned on openintab, but a couple of times I've opened a new tab and then used the search box - I just think it should use the blank tab instead of creating another one and leaving the blank tab blank.

Comment 3

13 years ago
See bug 320989 and bug 302352. Duping to the latter one. I think the former will cover the issue with the search bar.

*** This bug has been marked as a duplicate of 302352 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.