"run now" on filter causes error in javascript console

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Chris Moore, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060513 Ubuntu/dapper Firefox/1.5.0.3
Build Identifier: 1.5.0.2-0ubuntu2

Filters used to work for me, but now they don't.  They still run on incoming mail, but not when I click "run now" in the filters dialog, or select "run filters on folder" from the tools menu.

If I select a filter in the filters dialog and click "run now", I see an error message in the javascript console, as follows:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgFilterList.logStream]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://messenger/content/FilterListDialog.js :: runSelectedFilters :: line 437"  data: no]

When I first started using thunderbird, I created account settings for my gmail account, and told it to store messages in "gmail", rather than in "Local Folders".  At that point, filters were working fine, "run now" worked too.

Then, earlier today I realised that I really wanted all my mail in "Local Folders" instead of in "gmail", so I moved it all over, deleted the old gmail account settings and made them again, this time specifying that I wanted to use "Local Folders" for storage.

I think that is when the "run now" functionality broke.  In the filters dialog, at the top, I see "Filters for" and a drop-down menu.  The menu contains "gmail" as well as "Local Folders", and defaults to gmail each time I open the dialog.  I'm wondering whether the "run now" is looking in the non-existant gmail folder rather than in "Local Folders".  How can I make thunderbird forget that I used to have a "gmail" folder?

Reproducible: Always

Comment 1

12 years ago
Since you seem comfortable moving files/folders around, and your problems likely are related to that, I'd say it's easiest just to make a new clean thunderbird profile, and move the mail files and folders you need over to the new profile.

BTW, there are excellent user support forums over at http://forums.mozillazine.org/
(Reporter)

Comment 2

12 years ago
I made a new profile, and filters worked fine there.

I then returned to my old profile, and the problem returned for a while, but now it seems to have righted itself again.

While playing around I saw a few other errors in the javascript console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgFilterList.logStream]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://messenger/content/FilterListDialog.js :: runSelectedFilters :: line 437"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x8052ffff [nsIMsgFilterList.saveToDefaultFile]"  nsresult: "0x8052ffff (<unknown>)"  location: "JS frame :: chrome://messenger/content/FilterListDialog.js :: onFilterServerClick :: line 188"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x8052ffff [nsIMsgFilterList.saveToDefaultFile]"  nsresult: "0x8052ffff (<unknown>)"  location: "JS frame :: chrome://messenger/content/FilterListDialog.js :: onFilterClose :: line 395"  data: no]

As you say, it could have been my tinkering with files in my profile that caused the problems.  Please reject the bug, and I'll raise another one if the problem reoccurs without future 'tinkering'.

Comment 3

12 years ago
->WFM per comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.