Any event listener inside a repeat crashes 1_8_0

RESOLVED FIXED

Status

Core Graveyard
XForms
--
critical
RESOLVED FIXED
11 years ago
a year ago

People

(Reporter: Allan Beaufour, Assigned: smaug)

Tracking

({fixed1.8.0.5, fixed1.8.1})

Trunk
fixed1.8.0.5, fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

618 bytes, application/xhtml+xml
Details
6.85 KB, patch
Allan Beaufour
: review+
Doron Rosenberg (IBM)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
With the sync from bug 339087, any event listener inside repeat content makes firefox (1_8_0) crash on exit. For example:

<xf:repeat nodeset="x">
  <xf:message ev:event="foo-bar" level="modal">
  </xf:message>
</xf:repeat>
(Reporter)

Comment 1

11 years ago
Created attachment 223180 [details]
Testcase (crasher)

On exit, this crashes on 1_8_0. At least on localhost. Let's see if it does from bugzilla too...
(Reporter)

Comment 2

11 years ago
Is this bug 330526?
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Is this bug 330526?

It is. Aïe, why has it not been brought to 1_8_0?

*** This bug has been marked as a duplicate of 330526 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

11 years ago
I'm opening this because we can have a workaround for 1.8
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

11 years ago
Created attachment 223183 [details] [diff] [review]
proposed patch

Allan, could you test this with 1.8.x branch.
When I took out the patch for 330526, I could reproduce the
crash also in trunk but this patch helped for that.
Assignee: allan → Olli.Pettay
Status: REOPENED → ASSIGNED
Attachment #223183 - Flags: review?
(Assignee)

Comment 6

11 years ago
And note, RemoveModelFromDocument() is not needed in nsXFormsModelElement::OnDestroyed() because it is already 
called in nsXFormsModelElement::WillChangeDocument
(Assignee)

Updated

11 years ago
Attachment #223183 - Flags: review? → review?(allan)
(Reporter)

Comment 7

11 years ago
(In reply to comment #5)
> Created an attachment (id=223183) [edit]
> proposed patch
> 
> Allan, could you test this with 1.8.x branch.
> When I took out the patch for 330526, I could reproduce the
> crash also in trunk but this patch helped for that.

It fixes 1_8_0! Say joy!!

But could you include the same fix-approach for the focus listener in contextcontainer too? I fear that it might lead to the same crash one day.
(Reporter)

Comment 8

11 years ago
Comment on attachment 223183 [details] [diff] [review]
proposed patch

(In reply to comment #7)
> (In reply to comment #5)
> > Created an attachment (id=223183) [edit]
> > proposed patch
> > 
> > Allan, could you test this with 1.8.x branch.
> > When I took out the patch for 330526, I could reproduce the
> > crash also in trunk but this patch helped for that.
> 
> It fixes 1_8_0! Say joy!!
> 
> But could you include the same fix-approach for the focus listener in
> contextcontainer too? I fear that it might lead to the same crash one day.

Ah, got it. It was not because we did not remove the listener, but when we did it.

Thanks Olli!

r=me
Attachment #223183 - Flags: review?(allan) → review+
(Assignee)

Updated

11 years ago
Attachment #223183 - Flags: review?(doronr)

Updated

11 years ago
Attachment #223183 - Flags: review?(doronr) → review+
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch
(Reporter)

Updated

11 years ago
Keywords: fixed1.8.1
(Reporter)

Updated

11 years ago
Keywords: fixed1.8.0.5
(Reporter)

Updated

11 years ago
Whiteboard: xf-to-branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.