Mozilla/Macromedia hangs on Adobe advertisement

RESOLVED INVALID

Status

SeaMonkey
UI Design
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: Mark Space, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915

The page above, with the Adobe Acrobat advertisement, locks up the browser hard.  I had to use the Task Manager to close it.

I have it running right now, and it pegs the system at 100%.  It seems to not crash right away, maybe if I loaded a few more pages and switched around between them it would hang again, but the Task Manager is pegged at 100% CPU usage.

It occurs to me that this could be tricky to handle, but any sub-process or plugin that Mozilla is running should not be allowed 100% CPU.  Save a little for the browser, and ... here's the tricky part... allow me to reduce the priority of the plug-in if I want to.  (Reduce priority as in CPU run priority; same as "nice" in Unix systems.)

Reproducible: Sometimes

Steps to Reproduce:
1. Get Adobe ad running
2. Load up other pages, browse around
3. Go back to NYTimes page, browser will stop responing.  Sorry I can't say more.

Actual Results:  
No response.

Expected Results:  
Wanted some kind of response.

The system stopped responding to mouse wheel events first, then stopped responding period.
(Reporter)

Comment 1

12 years ago
Well, scratch the "reproducable" part, I can't reproduce it.

Note this happened at the end of the day, after the browser (and the mail reader) had basically be running for 7 hours straight.  (Yes I set them up and leave them running all day.)

I'll try to reproduce it again later.
(Reporter)

Comment 2

12 years ago
Well, it just happened again.

Same web site (nytimes.com), same Java advertising app.  Again, I've been running all day with both Mozilla and email open, so I assume that it's a requirement for reproduction.

This time when I say it start to happen, I tried to go to edit-preferences and disable jscript and java.  This went ok (if slowly) until I hit OK and then it just locked up hard.

I switched to the email window, which was also slow but working.  Then I tried closeing the email program.  Total lock up again.

I played a game while I waited for anything to happen.  The game was slow at first but returned to normal speed after about two minutes.  So, there seems to be some sort of global resource issue.

This entire time the CPU performance bar (Task Manager) was at 100%, and showing some red too (which I think means ready processes are blocked, which is bad).  Eventually I had to use the Task Manager to end Mozilla and the email window, neither were responding.  

BTW I checked for viruses and I seem to be clean.  (FreeBSD server and firewall! :))

That's all for now!

Is there some logging or debuging I can turn on to help you?  What more information would you need?
(Reporter)

Comment 3

12 years ago
It did it **again**

Some body give this issue some love please!

I switched to Firefox...
I image the particular advertisement is now long gone.
*I imagine that
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.