Last Comment Bug 339258 - Dynamically update provider menupopup
: Dynamically update provider menupopup
Status: RESOLVED DUPLICATE of bug 340677
[swag:1.5d] 181b1+
:
Product: Toolkit
Classification: Components
Component: Safe Browsing (show other bugs)
: 2.0 Branch
: All All
: P1 normal (vote)
: Firefox 2 beta1
Assigned To: Ryan Flint [:rflint] (ping via IRC for reviews)
:
:
Mentors:
Depends on: 338598 339872
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 13:27 PDT by Ryan Flint [:rflint] (ping via IRC for reviews)
Modified: 2014-05-27 12:25 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ryan Flint [:rflint] (ping via IRC for reviews) 2006-05-25 13:27:08 PDT
Remove the hardcoded "Google" sting from bug 337774 and provide a means of updating the list based on the prefs from bug 338598.
Comment 1 Tony Chang (Google) 2006-06-07 16:23:36 PDT
I've added support for this.  The pref to set a provider is browser.safebrowsing.dataProvider, and int.  The provider names are browser.safebrowsing.provider.0.name, browser.safebrowsing.provider.1.name, etc.
Comment 2 Mike Beltzner [:beltzner, not reading bugmail] 2006-07-05 13:04:42 PDT
jwalden: does this now count as a dupe against 340677?
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2006-07-05 15:49:36 PDT
(In reply to comment #2)
> jwalden: does this now count as a dupe against 340677?

For some definition of "dynamically".  If you update the preferences while the dialog is open (I don't know whether this is actually possible using a sanctioned method of installing safebrowsing providers, but you could do it with about:config), the dialog won't update too, but reopening the dialog will regenerate the update provider menupopup entries.
Comment 4 Mike Beltzner [:beltzner, not reading bugmail] 2006-07-05 19:28:07 PDT
That's an edgy-enough case to satisfy me. I don't think this needs to live update.

*** This bug has been marked as a duplicate of 340677 ***

Note You need to log in before you can comment on or make changes to this bug.