jimfeist.com - bad browser sniffing

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: Peter Moon, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Dear Sirs:

Firefox has disabled (unintentionally) a website I use every day for sports information, that website being www.jimfeist.com.

Your browser does not allow the menus associated with each of the ten tab buttons at the top of the screen to open where they are supposed to, which is directly UNDER the tab buttons themselves.

Instead, Firefox opens all ten menus along the LEFT EDGE of the screen (where they are useless, and where I am unable to click on them).

I was really hoping you could fix this problem. Please let me know how long it will take.

Thank you for your assistance.

Gratefully yours,
Peter Moon
petermoonraw@yahoo.com


Reproducible: Always

Steps to Reproduce:
1. Visit www.jimfeist.com
2. Click on any of the ten purple tab buttons on the top of the screen
3. Your browser then disables the website by opening menus in the wrong place

Actual Results:  
Menus open along left edge of the screen (where they are useless and where I am unable to click on them)!

Expected Results:  
Menus are supposed to open DIRECTLY UNDER the tab buttons themselves.
Please correct this bug in your browser as soon as possible.
Thank you.


Please contact me at petermoonraw@yahoo.com with an estimated time of when this problem will be fixed.
Again, thank you for your assistance.

Comment 1

12 years ago
Hmm clicking on the tabs for me opens the page in a new tab.
Severity: critical → normal
This is not a bug in Firefox. Firefox is displaying the site exactly as they've written it (minus the IE proprietary JS). Please report the issue to them instead: http://whois.domaintools.com/jimfeist.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

12 years ago
Firefox isn't interfacing properly with www.jimfeist.com -- a website that thousands of people use every day for sports information.

Forget about "worms," "viruses" and "trojan horses" for a moment.

This is a far bigger problem dealing with the way Firefox fundamentally interacts with high-traffic websites, in this case www.jimfeist.com. Because of the way Firefox was written, it renders the website useless.

Users are unable to click on any of the menus that come up when moving the arrow over a tab button because the menus appear in the wrong place -- along the left edge of the screen!

Internet Explorer doesn't do this!  You are mistaken when you say Firefox is presenting the website "exactly as it is written".  Internet Explorer is reporting it exactly as it is written.  Not Firefox.

Someone at Firefox said, “Hmmm. Clicking on the tabs opens another webpage.”

Forget about CLICKING on the tabs.  These are MENU tabs.  Each tab button is automatically supposed to open its own menu underneath it (as it doesn when using Internet Explorer).

If you don't believe there's something wrong with Firefox, visit jimfeist.com using Internet Explorer and move your mouse over one of the ten purple tabs at the top of the screen.

Internet Explorer brings the menu up at the correct location, which is directly underneath the tab, instead of along the left edge of the screen where it is impossible to use it.

Please fix that part of the Firefox browser's code that is causing this website's menus to appear in the wrong place, thereby rendering them useless.

Please get some programmers to fix Firefox so that jimfeist.com can be navigated as it can when using Internet Explorer.

Thank you for your assistance.

Sincerely,
Peter Moon
petermoonraw@yahoo.com
Severity: normal → critical
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Firefox has disabled my website! → Firefox has disabled this website

Comment 4

12 years ago
function initializeDIVs()
{
	DIVLoaded = DynLayerInit();
	
	DIVMenu1.elm.onmouseover = showDIVMenu1
	DIVMenu1.elm.onmouseout = hideDIVMenu1
	DIVMenu2.elm.onmouseover = showDIVMenu2
	DIVMenu2.elm.onmouseout = hideDIVMenu2
	DIVMenu3.elm.onmouseover = showDIVMenu3
	DIVMenu3.elm.onmouseout = hideDIVMenu3
	DIVMenu4.elm.onmouseover = showDIVMenu4
	DIVMenu4.elm.onmouseout = hideDIVMenu4
	DIVMenu5.elm.onmouseover = showDIVMenu5
	DIVMenu5.elm.onmouseout = hideDIVMenu5
	DIVMenu6.elm.onmouseover = showDIVMenu6
	DIVMenu6.elm.onmouseout = hideDIVMenu6
	DIVMenu7.elm.onmouseover = showDIVMenu7
	DIVMenu7.elm.onmouseout = hideDIVMenu7
	DIVMenu8.elm.onmouseover = showDIVMenu8
	DIVMenu8.elm.onmouseout = hideDIVMenu8
	DIVMenu9.elm.onmouseover = showDIVMenu9
	DIVMenu9.elm.onmouseout = hideDIVMenu9
	DIVMenu10.elm.onmouseover = showDIVMenu10
	DIVMenu10.elm.onmouseout = hideDIVMenu10
	DIVMenu11.elm.onmouseover = showDIVMenu11
	DIVMenu11.elm.onmouseout = hideDIVMenu11
	
	if (is.ie)
	{
		document.all.DIVMenu1Div.style.left = 60;
		document.all.DIVMenu2Div.style.left = 211;
		document.all.DIVMenu3Div.style.left = 363;
		document.all.DIVMenu4Div.style.left = 515;
		document.all.DIVMenu5Div.style.left = 667;
		document.all.DIVMenu6Div.style.left = 10;
		document.all.DIVMenu7Div.style.left = 161;
		document.all.DIVMenu8Div.style.left = 313;
		document.all.DIVMenu9Div.style.left = 465;
		document.all.DIVMenu10Div.style.left = 617;
		document.all.DIVMenu11Div.style.left = 10;
		document.all.DIVMenu1Div.style.top = 115;
		document.all.DIVMenu2Div.style.top = 115;
		document.all.DIVMenu3Div.style.top = 115;
		document.all.DIVMenu4Div.style.top = 115;
		document.all.DIVMenu5Div.style.top = 115;
		document.all.DIVMenu6Div.style.top = 133;
		document.all.DIVMenu7Div.style.top = 133;
		document.all.DIVMenu8Div.style.top = 133;
		document.all.DIVMenu9Div.style.top = 133;
		document.all.DIVMenu10Div.style.top = 133;
		document.all.DIVMenu11Div.style.top = 151;
	}

and

// BrowserCheck Object
function BrowserCheck() {
	var b = navigator.appName
	if (b=="Netscape") this.b = "ns"
	else if (b=="Microsoft Internet Explorer") this.b = "ie"
	else this.b = b
	this.version = navigator.appVersion
	this.v = parseInt(this.version)
	this.ns = (this.b=="ns" && this.v>=4)
	this.ns4 = (this.b=="ns" && this.v==4)
	this.ns5 = (this.b=="ns" && this.v==5)
	this.ie = (this.b=="ie" && this.v>=4)
	this.ie4 = (this.version.indexOf('MSIE 4')>0)
	this.ie5 = (this.version.indexOf('MSIE 5')>0)
	this.min = (this.ns||this.ie)
}
is = new BrowserCheck()

seems to tell me that this is just bad browser-sniffing.
This is neither critical nor valid. The check in comment 4 is exactly what I was referring to when I said it was functioning as written. I'll repeat myself for what I hope to be the last time: The only one's at fault for this are the webmasters of jimfeist.com. If you want this resolved, contact them: http://whois.domaintools.com/jimfeist.com 
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID

Comment 6

12 years ago
Or, this could be moved to tech evangelism, where it belongs.
Status: RESOLVED → UNCONFIRMED
Component: General → English US
Product: Firefox → Tech Evangelism
Resolution: INVALID → ---
Summary: Firefox has disabled this website → jimfeist.com - bad browser sniffing

Updated

12 years ago
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general → english-us

Comment 7

11 years ago
This looks like it's been fixed, as the menus appear in the right place (and work) in both Camino-trunk and Firefox 2.

Comment 8

11 years ago
Agreed the webmaster of jimfeist fixed the menu issues.
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.