Tools .. Options .. Display .. selection of background color for main windows

RESOLVED DUPLICATE of bug 302633

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 302633
12 years ago
10 years ago

People

(Reporter: 19john28, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Thunderbird 1.0.7 (20050923)

I have a suggestion that seems simple, but may entail more work than I think.

UNDER Thunderbird ...Tools ... Options ... Display ... >>

"Plain Text Messages" offers a "Color" selection

"HTML Messages" offers a "Background color"

The next, or next to next, update of T-bird should include a color [background] selection for the Opening Window, Compose, Inbox, Address Book, and Folders etc. All a single selection available without search for something called "Stylish" or the like. And accessed just as are the above colors.

Such a selection may have been planned for later or just overlooked.

Thanks for looking here. [No hurry] Thunderbird is the greatest.  John

Reproducible: Always

Steps to Reproduce:
1.Select "Tools"
2.Select "Options"
3.Select "Display"

Actual Results:  
None available at this time as no choice is provided

Expected Results:  
Results as expected. Added selection requested.

I and many others have problems with glare when using a PC over a period of time. Looking at black type on a plain white screen is uncomfortable. Like a bad chair. Partial background color selection is helpful, but seems to fall short of the objective.

Comment 1

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> Build Identifier: Thunderbird 1.0.7 (20050923)
> 
> I have a suggestion that seems simple, but may entail more work than I think.
> 
> UNDER Thunderbird ...Tools ... Options ... Display ... >>
> 
> "Plain Text Messages" offers a "Color" selection

That's only the color for quoted text.

> "HTML Messages" offers a "Background color"

Both colors here apply to received messages that don't specify their own colors -- including plain text (see bug 283268); these values are also used for plain-text message composition.  See more below.

> The next, or next to next, update of T-bird should include a color
> [background] selection for the Opening Window, Compose, Inbox, Address Book,
> and Folders etc. 

"Opening Window"?  Meaning "account central" (what you see when you select an account in the folder pane) or "start page" (what appears in the message pane on startup)?  I don't think these are easily customizeable.

For HTML Compose, you can specify the colors in Options|Composition|HTML Options.

I believe (I could be mistaken) that, in the default theme, the background colors for the folder and thread panes follow the default settings from the OS.
(These colors can be overridden, and are in some themes.)  If you change the Windows colors, then apps like Word will also follow your preferences.

Then, assuming you have your Windows color settings at a lower intensity the way you like, you can set the preference  browser.display.use_system_colors  to True.  This overrides the color settings described above, so that plain-text message display and composition, and display of HTML messages that don't specify color, follow your Windows settings as well.

To set that pref:   Options | Advanced | General | Config Editor; locate the pref and double-click to toggle it.



> I and many others have problems with glare when using a PC over a period of
> time. Looking at black type on a plain white screen is uncomfortable. Like a
> bad chair. Partial background color selection is helpful, but seems to fall
> short of the objective.

Another option is to search for a theme that sets up these colors in a reasonable fashion.

Comment 2

10 years ago
Duplicate of bug 302633?

Updated

10 years ago
Assignee: mscott → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: General → Mail Window Front End
OS: Windows XP → All
QA Contact: general → front-end
Hardware: PC → All
Resolution: --- → DUPLICATE
Duplicate of bug: 302633
You need to log in before you can comment on or make changes to this bug.