COMMA symbol in a "From" header messes up its display

RESOLVED DUPLICATE of bug 254519

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 254519
12 years ago
12 years ago

People

(Reporter: Rimas Kudelis, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; lt-LT; rv:1.8.0.3) Gecko/20060523 Ubuntu/dapper Firefox/1.5.0.3
Build Identifier: v.1.5.0.2

When in a FROM (and, probably, TO/CC/BCC) header there is a COMMA (U+002c) symbol, the header gets split at it and displayed improperly in message listing and preview pane/window.

The symptoms are as following: when you recieve a message, you see only the first part (the one before a comma) of the senders name in the message listing, and you only see the second part of it (the one after comma) in the preview pane and preview window.

This problem only happens when the full name of the sender is not wrapped in quotes, but is QP-encoded (I think it should show up for Base64 too).

Reproducible: Always

Steps to Reproduce:
1. Send yourself a message with a from address in a form of "Somename, Somename <username@servername.tld>", make sure the sender name is not wrapped in quote symbols, but rather QP or B64-encoded.
2. recieve the message in Thunderbird
3. Compare how its sender name looks in message listing and in the preview pane.

Actual Results:  
The sender name looks differently in the message listing pane (where you only see the first part of it) and in the preview pane/window (where you see the second part). 

Expected Results:  
The sender name should look exactly the same in all those places.

I'm providing a screenshot of this problem.
(Reporter)

Comment 1

12 years ago
Created attachment 223539 [details]
A screenshot of the problem in action

Comment 2

12 years ago
dupe of bug 254519 ?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> dupe of bug 254519 ?
> 

right.
duping.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.