Closed Bug 339436 Opened 14 years ago Closed 14 years ago

ensure all menus and menuitems have ID's.

Categories

(Calendar :: Sunbird Only, defect, trivial)

Sunbird 0.3a2
x86
Windows XP
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: chalkwhite, Assigned: ssitter)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060507 Mozilla Sunbird/0.3a2

my extension relys on menu and menuitem ID's, if some are missing it cannot function on those items, please make sure all items have ID's, thank you :-)

Reproducible: Always




the extension in mind is CuteMenus - Crystal SVG
Version: unspecified → Sunbird 0.3a2
It'd be most helpful if you could provide a list of the menus (ideally line numbers) that have this problem.
(In reply to comment #1)
> It'd be most helpful if you could provide a list of the menus (ideally line
> numbers) that have this problem.
> 

ok heres the ones i could find:

http://lxr.mozilla.org/mozilla/source/calendar/resources/content/calendar.xul

lines 253 through to 296

then these:

323
316
326
357

there were 2 in the help menu but it seems they have been removed from the xul.
(In reply to comment #2)
I think this file is not used in Sunbird. For Sunbird I see only two entries in the main menubar that have no ID: 'Help->Help Content' and 'Help->Release Notes'.
http://lxr.mozilla.org/mozilla/source/calendar/sunbird/base/content/calendar-menubar.inc#436
yup those ones in the context menu, since the help menu items dont do anything yet they are not that important, but the context menu isnt that small and is frequently used.
This patch adds ID's to the general context menu, the task pane context menu and the toolbar customize context menu.
Assignee: nobody → ssitter
Status: UNCONFIRMED → ASSIGNED
Attachment #233452 - Flags: second-review?(mvl)
Attachment #233452 - Flags: first-review?(mattwillis)
Comment on attachment 233452 [details] [diff] [review]
add missing context menu ID's

Looks good.
r1=lilmatt
Attachment #233452 - Flags: first-review?(mattwillis) → first-review+
Comment on attachment 233452 [details] [diff] [review]
add missing context menu ID's

r=mvl
Attachment #233452 - Flags: second-review?(mvl) → second-review+
Whiteboard: [checkin needed]
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
You need to log in before you can comment on or make changes to this bug.