Closed Bug 339514 Opened 14 years ago Closed 7 years ago

Let the user edit the command line arguments for the Feed Reader application.

Categories

(Firefox Graveyard :: RSS Discovery and Preview, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: lukrez, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3

When the user chooses to use a local feed reader, give the opportunity to adjust a command line pattern of the application that acts as feed reader.  For example, "akregator" recognizes the following command line

  akregator --addfeed <url>

but fails to proceed, if it is called like

  akregator <url>

Reproducible: Always
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060526 Minefield/3.0a1 - Build ID: 0000000000
Confirmed.

Related to bug #308815, bug #281903.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 2.0 Branch
Can you go to about:config and change the option for browser.feeds.handlers.application to include the argument? Does this work?
OS: Linux → All
Hardware: PC → All
Version: 2.0 Branch → Trunk
It would appear not to work here (I pointed it towards a shell script I knocked together which outputted a file if it was passed the "--help" switch - no file was outputted even when the "--help" switch was present in browser.feeds.handlers.application).
I'm a little scared thinking about the UI for this. Any attempt to solve this "problem" should be addressed uniformly across all parts of the browser that let the user pick an app to handle something. Help appreciated, of course.

Before anyone says "oh just make the text box user-editable", remember:

- validating input
- etc.

Priority: -- → P4
Target Milestone: --- → Future
Blocks: 348450
(In reply to comment #4)
> I'm a little scared thinking about the UI for this. Any attempt to solve this
> "problem" should be addressed uniformly across all parts of the browser that
> let the user pick an app to handle something. Help appreciated, of course.
> 
> Before anyone says "oh just make the text box user-editable", remember:
> 
> - validating input
> - etc.
> 

the only answer is to make it freeform user-editable.  there is no way Fx can know what args are required by any multitude of apps, and in no way can/should Fx be responsible for their validation.  this level of user handholding is unnecessary.

right now, Fx subscribing rss to Tb is broken because Fx does not pass -mail feed:%url.  and Fx can't handle starting Tb with those arguments in the pref.
another way to solve this problem could be to preface the subscription url with feed: or feed://, give that url to the OS and let the OS invoke the default system feed reader instead of trying to invoke a feed client directly from Firefox where Firefox then has to figure out the arguments to use. This way the OS figures out how to invoke the default feed reader. And the OS already knows how to invoke the feed reader with a URL (i.e. feed\shell\open\command in the windows registry)
Duplicate of this bug: 420859
Duplicate of this bug: 438967
I think this is just a little too specialized for the core product. Maybe this would be useful as an add-on, but I don't think it's worth it for the general case.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
(In reply to Mike Conley (:mconley) from comment #9)
> I think this is just a little too specialized for the core product. Maybe
> this would be useful as an add-on, but I don't think it's worth it for the
> general case.

It's OK -- in the meantime Firefox and akregator play well together, akregator now simply accepts to be called like

  akregator <url>

in order to add new feeds.  For the change in akregator, see <https://bugs.kde.org/show_bug.cgi?id=127322#c6>.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.