Closed Bug 339532 Opened 15 years ago Closed 15 years ago

Roaming not packaged in installer builds

Categories

(SeaMonkey :: Installer, defect)

x86
OS/2
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mozilla, Assigned: mozilla)

Details

(Keywords: fixed1.8.1, Whiteboard: [schrep-181approval pending - os/2 only])

Attachments

(1 file)

It appears that roaming does not get packaged or installed with the installer EXE for SeaMonkey and contrary to the Windows installer one cannot select/deselect it during custom install.
Attached patch The fixSplinter Review
Hmm, I didn't have time yet to really test this on the trunk but it should work, it basically copies what Windows does. I only tested with the 1.8.0 branch so far, but had to adapt the patch slightly for the trunk.
Attachment #223630 - Flags: review?(mozilla)
Summary: Roaming not packages in installer builds → Roaming not packaged in installer builds
Comment on attachment 223630 [details] [diff] [review]
The fix

mkaply: review reminder. :-)

Actually, I only now notice that this also contains a fix so that the binaries in the EXE installer get stripped (lxLite) before being packaged into the XPIs.
Comment on attachment 223630 [details] [diff] [review]
The fix

r=mkaply
Attachment #223630 - Flags: review?(mozilla) → review+
Fixed on trunk.

Note to self: ask for approvals in a few days.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Comment on attachment 223630 [details] [diff] [review]
The fix

OS/2 only packaging change that was tested for a month on trunk.
Attachment #223630 - Flags: approval1.8.1?
Whiteboard: [schrep-181approval pending - os/2 only]
Comment on attachment 223630 [details] [diff] [review]
The fix

a=schrep/beltnzer for drivers.
Attachment #223630 - Flags: approval1.8.1? → approval1.8.1+
Fixed on branch, too.
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.